Bug 1306406 - About to run task 'java.util.concurrent.FutureTask' from: java.lang.Exception
About to run task 'java.util.concurrent.FutureTask' from: java.lang.Exception
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
3.6.2.6
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3.2
Assigned To: Eli Mesika
Pavel Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 13:14 EST by Alexander Wels
Modified: 2016-02-17 02:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 02:28:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: exception+
mgoldboi: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53508 ovirt-engine-3.6 MERGED logging: remove debug message with no value 2016-02-15 07:09 EST
oVirt gerrit 53522 ovirt-engine-3.6.3 MERGED logging: remove debug message with no value 2016-02-15 07:33 EST

  None (edit)
Description Alexander Wels 2016-02-10 13:14:20 EST
Description of problem:
I am seeing a ton of the $Summary exceptions in my log. Not sure what the exact issue is.

Version-Release number of selected component (if applicable):


How reproducible:
Start engine, let it run and the log will contain the exceptions

Actual results:
Above exception in log


Expected results:
No exceptions in the log due to whatever issue this is.

Additional info:
Comment 2 Alexander Wels 2016-02-10 13:17:09 EST
This is what looks like the important part of the log.

2016-02-10 16:46:46,611 DEBUG [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback] (DefaultQuartzScheduler_Worker-40) [] Executed batch
2016-02-10 16:46:46,614 DEBUG [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback] (DefaultQuartzScheduler_Worker-40) [] Executing batch for procedure UpdateNumaNodeStatistics
2016-02-10 16:46:46,614 DEBUG [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback] (DefaultQuartzScheduler_Worker-40) [] Mapped params: [v_cpu_idle, v_numa_node_id, v_usage_mem_percent, v_
cpu_sys, v_usage_cpu_percent, v_cpu_user, v_mem_free]
2016-02-10 16:46:46,614 DEBUG [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback] (DefaultQuartzScheduler_Worker-40) [] Mapped params: [v_cpu_idle, v_numa_node_id, v_usage_mem_percent, v_
cpu_sys, v_usage_cpu_percent, v_cpu_user, v_mem_free]
2016-02-10 16:46:46,615 DEBUG [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback] (DefaultQuartzScheduler_Worker-40) [] Executed batch
2016-02-10 16:46:46,619 DEBUG [org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil] (org.ovirt.thread.pool-8-thread-30) [] About to run task 'java.util.concurrent.FutureTask' from: java.lang.Exception
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalThreadExecutor.beforeExecute(ThreadPoolUtil.java:53) [utils.jar:]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.7.0_95]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_95]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_95]

2016-02-10 16:46:46,619 DEBUG [org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil] (org.ovirt.thread.pool-8-thread-35) [] About to run task 'java.util.concurrent.FutureTask' from: java.lang.Exception
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalThreadExecutor.beforeExecute(ThreadPoolUtil.java:53) [utils.jar:]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.7.0_95]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_95]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_95]
Comment 4 Oved Ourfali 2016-02-13 02:49:24 EST
Eli, can you take a look, and then pass it to the right team, if needed?
Comment 7 Gil Klein 2016-02-17 02:28:53 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.