This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306421 - Server 500 Error When uploading Manifest
Server 500 Error When uploading Manifest
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHCI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Jesus M. Rodriguez
Tasos Papaioannou
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 14:38 EST by Adam Haile
Modified: 2016-09-13 12:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Offending manifest (108.65 KB, application/zip)
2016-02-10 14:38 EST, Adam Haile
no flags Details

  None (edit)
Description Adam Haile 2016-02-10 14:38:54 EST
Created attachment 1122891 [details]
Offending manifest

Description of problem:
On the latest RHCI, when trying to do a disconnected install and upload the required manifest file, the server throws a 500 error (though absolutely nothing is shown on the UI, looking at the console was required).


Version-Release number of selected component (if applicable):


How reproducible: 100% with the attached file


Steps to Reproduce:
1. Get to SHN Subscription section of install for RHEV/CF
2. Choose disconnected mode
3. Upload the attached manifest zip file

Actual results:
Nothing happens on the UI. Javascript console shows 500 Error


Expected results:
Manifest uploads and is verified by the UI


Additional info:
See foreman log: https://gist.github.com/anonymous/56af1716e5d7ce778821
Comment 1 John Matthews 2016-02-10 14:46:30 EST
Was related to a manifest uploaded that lacked RHCI subscriptions.
Comment 2 Jesus M. Rodriguez 2016-02-10 14:52:05 EST
The ultimate cause was an entitlement that had no branding field. We were logging some debug information including the branding field even though we don't use it in the application. I fixed it by removing the offending debug statement.

https://github.com/fusor/fusor/pull/677
Comment 4 Tasos Papaioannou 2016-03-23 14:43:03 EDT
Verified on QCI-1.0-RHEL-7-20160321.t.1.
Comment 10 errata-xmlrpc 2016-09-13 12:26:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.