Bug 1306426 - plugin not installed automatically
plugin not installed automatically
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 15:16 EST by Mikhail
Modified: 2017-01-31 06:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-30 04:47:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast (15.20 MB, application/ogg)
2016-02-10 15:16 EST, Mikhail
no flags Details

  None (edit)
Description Mikhail 2016-02-10 15:16:47 EST
Created attachment 1122892 [details]
screencast

Description of problem:
As you see from screencast printer added automatically after connect.
But anyway for complete installation I needed manually run hp-plugin.
I have two questions:
1. Why launched GNOME Software during installation process?
2. If GNOME Software is already launched, why it can't automatically install hp-plugin?
Comment 1 Paulo Fidalgo 2016-02-29 16:31:44 EST
I have the same problem with an HP 1102W, with FC22. Every time there's an update on HPLip, I need to manually setup the printer again.
Comment 2 Fedora Admin XMLRPC Client 2016-06-24 06:37:39 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Dominik 'Rathann' Mierzejewski 2016-08-31 07:45:42 EDT
I have the same printer (M1132MFP) and I share your pain. Unfortunately, this printer requires proprietary plugins to work and HP ignored my request to change the license, so they can't even be packaged in RPMFusion.
Comment 4 Dominik 'Rathann' Mierzejewski 2016-08-31 13:45:44 EDT
Please note that you can use the foo2zjs driver packaged in RPMFusion with this printer (set it up as LaserJet Pro P1102).
Comment 5 Zdenek Dohnal 2017-01-30 04:47:49 EST
I am sorry, but as Dominik said, there are drivers, which are not open source and they need to download manually every new version of hplip. Closing it as NOTBUG.
Comment 6 Mikhail 2017-01-30 04:58:16 EST
Ok, you not answer on first question:
1. Why launched GNOME Software during installation process?

And I don't really understand why GNOME Software can't download proprietary driver. Means this driver not shipped with Fedora and would be downloaded directly from vendor site. What laws would violated with this?
Comment 7 Zdenek Dohnal 2017-01-31 06:59:35 EST
When you are installing printer by Printers tool, it uses d-bus service, which is provided by system-config-printer. That service runs ppdsloader, which asks PackageKit (which works with Gnome Software) to install driver based on device id. And because driver is proprietary and is not in repositories, it ends with error.
Gnome Software works above whatever repositories you enable in your system. So if you want to install some driver by GS, it needs to be in repository - and proprietary driver cannot be in repository, because it has non free license and it means it cannot be distributed by us. That how GS works and if you have other question about it, I think I am not right person to ask - maybe some guys which works on Gnome Software could answer in better way - but I think this approach has meaning.

Note You need to log in before you can comment on or make changes to this bug.