Bug 130647 - [second write process hangs if another one is writing already,!!but in another database!!]
[second write process hangs if another one is writing already,!!but in anothe...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-23 09:21 EDT by Daniel Beuter
Modified: 2013-07-02 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 11:52:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Beuter 2004-08-23 09:21:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.51  [en]

Description of problem:

Subject: [second write process hangs if another one is writing 
already,!!but in another database!!]

>Description:
        <We have this mysql-server with two databases "internet" and 
"intranet".There are two data-collectors "server1" and "server2".Each 
writes in one database. Server1 in internet, server 2 in intranet.The 
problem is, if writing process(f.e.:Server1) is active and second 
one(server2) starts then the process of (server2) hangs.The only way 
to get this hanging process out of the system is to kill the 
process(id) in servername.pid.Afterwards killall -15 mysqld, then 
stop server and start it again.If I don´t do this way I have to 
reboot because the pidd of other msql processes block the restart of 
the server.(strange,isn`t it). Write -and- Read is possible without 
problems. But writing two processes in different databases is not 
possible at same time>
>How-To-Repeat:
        <code/input/activities to reproduce the problem (multiple 
lines)>
>Fix:
        <how to correct or work around the problem, if known 
(multiple lines)>

>Submitter-Id:  <submitter ID>
>Originator:    root
>Organization:
 <organization of PR author (multiple lines)>
>MySQL support: [none | licence | email support | extended email 
support ]
>Synopsis:      <more than one writeprocess impossible>
>Severity:      <[ critical ]>
>Priority:      <[ low | medium | high ] (one line)>
>Category:      mysql
>Class:         <[ sw-bug | doc-bug | change-request | support ] (one 
line)>
>Release:       mysql-4.0.20-standard (Official MySQL RPM)
>Server: /usr/bin/mysqladmin  Ver 8.40 Distrib 4.0.20, for pc-linux 
on i686
Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
This software comes with ABSOLUTELY NO WARRANTY. This is free 
software,
and you are welcome to modify and redistribute it under the GPL 
license

Server version          4.0.20-standard
Protocol version        10
Connection              Localhost via UNIX socket
UNIX socket             /var/lib/mysql/mysql.sock
Uptime:                 7 days 1 hour 31 min 24 sec

Threads: 2  Questions: 104795562  Slow queries: 7  Opens: 12664  
Flush tables: 1  Open tables: 62  Queries per second avg: 171.716
>C compiler:    2.95.3
>C++ compiler:  2.95.3
>Environment:
        <machine, os, target, libraries (multiple lines)>
System: Linux xxx.xxx.siemens.de 2.4.22-1.2197.nptlsmp #1 SMP Thu Jul 
1 15:05:23 EDT 2004 i686 i686 i386 GNU/Linux
Architecture: i686

Some paths:  /usr/bin/perl /usr/bin/make /usr/bin/gmake /usr/bin/gcc 
/usr/bin/cc
GCC: Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.3.
2/specs
Konfiguriert mit: ../configure --prefix=/usr --mandir=/usr/share/man 
--infodir=/usr/share/info --enable-shared --enable-threads=posix 
--disable-checking --with-system-zlib --enable-__cxa_atexit 
--host=i386-redhat-linux
Thread model: posix
gcc-Version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)
Compilation info: CC='gcc'  CFLAGS='-O2 -mcpu=i486 
-fno-strength-reduce'  CXX='gcc'  CXXFLAGS='-O2 -mcpu=i486 
-fno-strength-reduce                -felide-constructors 
-fno-exceptions -fno-rtti                  '  LDFLAGS=''  ASFLAGS=''
LIBC:
lrwxrwxrwx  1 root root 13 22. Jul 16:34 /lib/libc.so.6 -> libc-2.3.
2.so
-rwxr-xr-x  1 root root 1570384  7. Jan 2004  /lib/libc-2.3.2.so
-rw-r--r--  1 root root 2445156 27. Okt 2003  /usr/lib/libc.a
-rw-r--r--  1 root root 204 27. Okt 2003  /usr/lib/libc.so
Configure command: ./configure '--disable-shared' 
'--with-mysqld-ldflags=-all-static' 
'--with-client-ldflags=-all-static' '--with-server-suffix=-standard' 
'--without-embedded-server' '--without-berkeley-db' '--with-innodb' 
'--without-vio' '--without-openssl' '--enable-assembler' 
'--enable-local-infile' '--with-mysqld-user=mysql' 
'--with-unix-socket-path=/var/lib/mysql/mysql.sock' '--prefix=/' 
'--with-extra-charsets=complex' '--exec-prefix=/usr' 
'--libexecdir=/usr/sbin' '--libdir=/usr/lib' '--sysconfdir=/etc' 
'--datadir=/usr/share' '--localstatedir=/var/lib/mysql' 
'--infodir=/usr/share/info' '--includedir=/usr/include' 
'--mandir=/usr/share/man' '--enable-thread-safe-client' 
'--with-comment=Official MySQL RPM' 'CC=gcc' 'CFLAGS=-O2 -mcpu=i486 
-fno-strength-reduce' 'CXXFLAGS=-O2 -mcpu=i486 -fno-strength-reduce   
              -felide-constructors -fno-exceptions -fno-rtti          
        ' 'CXX=gcc'


Version-Release number of selected component (if applicable):
Linux version 2.4.22-1.2197.nptlsmp (bhcompile@tweety.build.redhat.
com) (gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-6)) #1 ,Your 
MySQL connection id is 14037 to server version: 4.0.20-standard  

How reproducible:
Always

Steps to Reproduce:
1.  2 databases on one server
2.  2 different write processes from 2 different data-collectors in 
different databases at same time
3.  SELECT	sum(d_pkts), sum(d_octets) , timestamp  , src_addr  , 
dst_addr , protocol , src_as , dst_as  FROM  `flows-20040816-14:59:
00` WHERE  (out_if_id = 19 OR in_if_id = 19) AND  timestamp >= 
'20040816-12:00:00'     
	        AND  timestamp <= '20040816-15:00:00'  GROUP BY protocol  , 
timestamp  , src_addr  , dst_addr  , src_as  , dst_as  ORDER BY 2  
DESC LIMIT 100   <--- thats the write process  for each process 
syntaxly the same
    

Actual Results:  the first starting process is working fine. the 
second one will hang and the connection stays (netstat) open. Also if 
I kill the process the connection is still open and the process also 
stays in ps -auxww


Expected Results:  Both loader processes should write their data in 
the database and close after their work

Additional info:
Comment 1 Tom Lane 2004-12-10 11:52:20 EST
I'm going to close this as an item that you should submit upstream,
ie, to www.mysql.com.  Red Hat does not support MySQL 4.0, and it
looks like we never will (plans are to go directly to 4.1).  I'd take
some interest in this issue if it is still present in 4.1, but we'd
still have to get MySQL AB involved to find a fix.

Note You need to log in before you can comment on or make changes to this bug.