Bug 1306495 - [Docs] [Admin] A description of how to remove a data storage domain must be added
[Docs] [Admin] A description of how to remove a data storage domain must be a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-3.6.5
: ---
Assigned To: Tahlia Richardson
Megan Lewis
http://www.ovirt.org/develop/release-...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 21:24 EST by Andrew Dahms
Modified: 2016-05-03 22:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-03 22:36:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2016-02-10 21:24:23 EST
In Red Hat Enterprise Virtualization 3.5, it became possible to import existing data storage domains into a RHEV environment. The workflow for this is outlined here -

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html-single/Administration_Guide/index.html#Importing_existing_ISO_or_export_storage_domains

This new functionality allows users to import existing data storage domains after an environment goes down, and re-import all the virtual machines. It also allows users to move a data storage domain from one data center to another by removing it from one data center and re-importing it into another.

A procedure outlining how to remove the data storage domain from a data center must be added with this use case in mind, including notes on considerations such as whether all virtual machines must be down at the time, and how to cleanly remove the data storage domain so that it can be re-imported as per the instructions above.
Comment 1 Lucy Bopf 2016-03-10 20:14:06 EST
Assigning to Tahlia for review.

Tahlia, most of the information required is already in the Administration Guide, but is somewhat scattered. The procedure (or set of procedures) should follow the workflow included in the bug description, and include the following:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html-single/Administration_Guide/index.html#Detaching_storage_domains_from_a_data_center

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html-single/Administration_Guide/index.html#Attaching_a_data_domain
Comment 2 Tahlia Richardson 2016-03-15 01:30:44 EDT
This bug seems like it's confusing two different processes. Attaching a storage domain is just taking a domain that exists in the environment and plunking it in a data centre. I could do a "Moving a storage domain from one data centre to another" section, but it would basically be "follow the procedure for detaching" and then "follow the procedure for attaching". 

On the other hand, importing a storage domain involves bringing in storage that is not currently in the environment anywhere. For example, if my RHEV env suddenly borked itself and I had to nuke it and set up a new one, I could just import the existing /storage/trichard/data directory into it, since it's no longer part of the old nuked env, and it would work without having to manually delete its contents first (if I understand correctly).
Comment 3 Tahlia Richardson 2016-03-21 02:56:46 EDT
After some clarification, what I'm seeing here is two scenarios and three procedures:

1. Migrate storage domain to a different data center
 a. In the same environment (detach from one and attach to another)
 b. In a different environment (remove from one and import to another)
2. Disaster recovery (import an existing data domain to a new environment after the death of the old one)

Various procedures for parts of this exist, as noted in comment 1, throughout the book, in the Data Centers chapter and the Storage chapter (because you can do almost all the same things through either, i.e Data Centers tab > Storage subtab vs Storage tab > Data Centers subtab).

Data Centers:
3.6. Data Centers and Storage Domains
 3.6.1. Attaching an Existing Data Domain to a Data Center
 [...]
 3.6.4. Detaching a Storage Domain from a Data Center
 3.6.5. Activating a Storage Domain from Maintenance Mode

Storage:
7.6. Importing Existing Storage Domains
7.7. Storage Tasks
 [...]
 7.7.2. Moving Storage Domains to Maintenance Mode
 [...]
 7.7.4. Activating Storage Domains
 7.7.5. Removing a Storage Domain

So far my plan is to add the three new procedures, which includes content from those listed above, to 3.6 Data Centers and Storage Domains (maybe Backups and Migration, too?). I also want to consolidate (there's some unnecessary duplication) and move the individual procedures to the Storage chapter.
Comment 9 Megan Lewis 2016-04-25 21:40:22 EDT
Merge request accepted and revision history entry added.

Note You need to log in before you can comment on or make changes to this bug.