Bug 1306521 - Multiple HTTP connections interrupts capsule sync
Multiple HTTP connections interrupts capsule sync
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: John Mitsch
Jitendra Yejare
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 02:24 EST by Jitendra Yejare
Modified: 2016-06-30 07:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-30 07:11:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitendra Yejare 2016-02-11 02:24:14 EST
Description of problem:
Multiple HTTP connections interrupting capsule sync on upgraded capsule from 6.0.8.

Version-Release number of selected component (if applicable):
Satellite 6.1.7 Compose #1

How reproducible:


Steps to Reproduce:
1. On Sat 6.0.8, Sync some repos in satellite and publish, promote them to some environment.
2. Don't sync capsule before upgrading to latest 6.1.
3. Upgrade the satellite and capsule to latest 6.1 version.
4. Trigger the capsule sync from satellite using hammer sync command.
5. Observe /var/log/messages in capsule.

Actual results:
Multiple HTTP connection request from capsule to Satellite interrupts capsule sync and throws worker errors and finally stops the entire sync.

Logs are Here: http://pastebin.com/0vgW2Bbm

Expected results:
Capsule sync success.

Additional info:
Comment 3 Mike McCune 2016-03-03 01:14:58 EST
There are no customer tickets aligned to this, moving out of 6.1.Z
Comment 5 John Mitsch 2016-06-22 10:41:55 EDT
I was not able to reproduce this on a 6.1 > 6.2 upgrade
Comment 6 Jitendra Yejare 2016-06-30 07:11:27 EDT
Verified ! 

@ Sat 6.2 GA Snap 18

Observation:
While syncing capsule with satellite, I saw HTTP connection requests but that doesnt halt the sync. And the sync completed successfully.

So closing this bug as WorksForMe !

Note You need to log in before you can comment on or make changes to this bug.