Bug 1306560 - Accessing program list in build_prog_details () should be lock protected
Accessing program list in build_prog_details () should be lock protected
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On:
Blocks: 1310970
  Show dependency treegraph
 
Reported: 2016-02-11 05:01 EST by Atin Mukherjee
Modified: 2016-06-16 09:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1310970 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:57:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2016-02-11 05:01:05 EST
Description of problem:

Currently build_prog_details() iterates over the rpcsvc's program list and constructs a local linked list. However the same happens with out any lock protection and hence this can cause a crash if some other writer threads modify the same list.

Version-Release number of selected component (if applicable):
Mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-11 05:09:31 EST
REVIEW: http://review.gluster.org/13428 (rpc : build_prog_details should iterate program list inside critical section) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2016-02-11 06:45:55 EST
REVIEW: http://review.gluster.org/13428 (rpc : build_prog_details should iterate program list inside critical section) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 3 Vijay Bellur 2016-02-12 06:31:06 EST
REVIEW: http://review.gluster.org/13428 (rpc : build_prog_details should iterate program list inside critical section) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 4 Vijay Bellur 2016-02-22 05:49:33 EST
REVIEW: http://review.gluster.org/13428 (rpc : build_prog_details should iterate program list inside critical section) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 5 Vijay Bellur 2016-02-22 13:07:15 EST
COMMIT: http://review.gluster.org/13428 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 663d1a5eed5a8aef6cfad4710e16d21740bf0da8
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 11 15:37:08 2016 +0530

    rpc : build_prog_details should iterate program list inside critical section
    
    While I was analyzing a glusterd crash from free_prog_details, a code
    walkthrough detects that we iterate over the rpc svc program list without been
    inside the criticial section. This opens up a possibility of a crash when there
    is a concurrent writer updating the same list. Solution is to read the list
    inside lock.
    
    Change-Id: Ib4b4b0022a9535e139cd3c00574aab23f07aa9d2
    BUG: 1306560
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/13428
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 6 Niels de Vos 2016-06-16 09:57:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.