Bug 1306573 - hosted engine appliance deployment fails with insufficient information.
hosted engine appliance deployment fails with insufficient information.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.5.7
Unspecified Unspecified
medium Severity medium
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Simone Tiraboschi
Artyom
integration
: Triaged, ZStream
Depends On: 1310139
Blocks: 1318612
  Show dependency treegraph
 
Reported: 2016-02-11 05:30 EST by Roman Hodain
Modified: 2016-08-23 17:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when attempting to deploy a self-hosted engine without enough free space on the storage the error message did not show what space was required and only showed the available space. This meant that the user needed to check in the documentation for the minimum required space. Now, a more complete error message is provided.
Story Points: ---
Clone Of:
: 1318612 (view as bug list)
Environment:
Last Closed: 2016-08-23 17:00:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53668 master MERGED storage: provide a more informative message on not enough space 2016-03-17 06:55 EDT
oVirt gerrit 54864 ovirt-hosted-engine-setup-1.3 MERGED storage: provide a more informative message on not enough space 2016-03-17 08:16 EDT

  None (edit)
Description Roman Hodain 2016-02-11 05:30:31 EST
Description of problem:
The hosted engine appliance deployment fails with ERROR:

2016-02-11 10:20:12 WARNING otopi.plugins.ovirt_hosted_engine_setup.vm.image image._disk_customization:125 Not enough free space, about 35 GiB are available
2016-02-11 10:20:12 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/vm/image.py", line 135, in _disk_customization
    estimate=estimate_gb
RuntimeError: Not enough free space, about 35 GiB are available

The documentation says:

Table 2.1. Hardware Requirements
Resource    Minimum 	                Recommended
Memory      4 GB RAM 	                16 GB RAM
Disk Space  25 GB writable disk space 	50 GB writable disk space 

The minimum is 25 GB so it should not fail with 35 iSCSI LUN. The user also cannot know that 5 GB will be taken by the metadata.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.6.1-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Try to install ova on 35GB LUN

Actual results:
Fails with error message
Not enough free space, about 35 GiB are available


Expected results:
Either the minimum is fallowed or a proper message is logged. User does not care how much memory they have, but how much memory they need.
Comment 1 Simone Tiraboschi 2016-02-17 08:09:56 EST
Are you using the RHEV-M appliance? in that case we simply take the disk size in the appliance OVF without asking and, if I'm not wrong, upstream it's 10 GB (no issue) but downstream is 50 GB and so 35 are not enough.

See also: rhbz#1300591
Comment 2 Roman Hodain 2016-02-17 08:22:51 EST
(In reply to Simone Tiraboschi from comment #1)
> Are you using the RHEV-M appliance? in that case we simply take the disk
> size in the appliance OVF without asking and, if I'm not wrong, upstream
> it's 10 GB (no issue) but downstream is 50 GB and so 35 are not enough.
> 
> See also: rhbz#1300591

Well that is understood, but the setup tool should say that. instead of 

RuntimeError: Not enough free space, about 35 GiB are available

It should say something like

RuntimeError: Not enough free space (50GB required), about 35 GiB are available on the target storage domain.

This bug is about the information which is provided bout the error by the tool. Not about the actual error.
Comment 4 Artyom 2016-04-11 11:32:26 EDT
Verified on ovirt-hosted-engine-setup-2.0.0-0.0.master.20160325145108.gita9a3495.el7.centos.noarch

Error: device 3514f0c5a516002ac has capacity of only 5120Mb while a minimum of 20480Mb is  required
Comment 6 errata-xmlrpc 2016-08-23 17:00:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1744.html

Note You need to log in before you can comment on or make changes to this bug.