Bug 1306603 - [Admin Portal] Uncaught exception occurred when switching between individual hosts/VM subtab in Hosts maintab
[Admin Portal] Uncaught exception occurred when switching between individual ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3.1
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Alexander Wels
Jiri Belka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 07:17 EST by Jiri Belka
Modified: 2016-07-26 06:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-26 06:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
oourfali: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47912 None None None 2016-02-17 11:16 EST

  None (edit)
Description Jiri Belka 2016-02-11 07:17:19 EST
Description of problem:

Uncaught exception occurred when switching between individual hosts/VM subtab in Hosts maintab.

~~~
13:00:27.057 Thu Feb 11 13:00:27 GMT+100 2016 remote
SEVERE: Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: d is null
	at Unknown.ms(Unknown Source)
	at Unknown.us(Unknown Source)
	at Unknown.i3(Unknown Source)
	at Unknown.l3(Unknown Source)
	at Unknown.v2(Unknown Source)
	at Unknown.vvf(Unknown Source)
	at Unknown.Scm(Unknown Source)
	at Unknown.bdm(Unknown Source)
	at Unknown.zvf(Unknown Source)
	at Unknown.Ju(Unknown Source)
	at Unknown.zu(Unknown Source)
	at Unknown.bu(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: d is null
	at Unknown.FVg(Unknown Source)
	at Unknown.Y7s(Unknown Source)
	at Unknown.b8s(Unknown Source)
	at Unknown.d8s(Unknown Source)
	at Unknown.dMr(Unknown Source)
	at Unknown.Uml(Unknown Source)
	at Unknown.gJp(Unknown Source)
	at Unknown.zIo(Unknown Source)
	at Unknown.VHo(Unknown Source)
	at Unknown.LIo(Unknown Source)
	at Unknown.dro(Unknown Source)
	at Unknown.kso(Unknown Source)
	at Unknown.Xso(Unknown Source)
	at Unknown.vQk(Unknown Source)
	at Unknown.Kds(Unknown Source)
	at Unknown.uvf(Unknown Source)
	at Unknown.d$(Unknown Source)
	at Unknown.F2(Unknown Source)
	at Unknown.v2(Unknown Source)
	at Unknown.vvf(Unknown Source)
	at Unknown.Scm(Unknown Source)
	at Unknown.bdm(Unknown Source)
	at Unknown.zvf(Unknown Source)
	at Unknown.Ju(Unknown Source)
	at Unknown.zu(Unknown Source)
	at Unknown.bu(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
1 24CAB70AF0299102FD3ABBE843149A34.cache.html:24106:12003
tDe() 24CAB70AF0299102FD3ABBE843149A34.cache.html:24106
NEe() 24CAB70AF0299102FD3ABBE843149A34.cache.html:22155
MEe() 24CAB70AF0299102FD3ABBE843149A34.cache.html:19721
bFe() 24CAB70AF0299102FD3ABBE843149A34.cache.html:9969
oLk() 24CAB70AF0299102FD3ABBE843149A34.cache.html:24148
gu() 24CAB70AF0299102FD3ABBE843149A34.cache.html:18346
Ju() 24CAB70AF0299102FD3ABBE843149A34.cache.html:21116
zu() 24CAB70AF0299102FD3ABBE843149A34.cache.html:17692
bu() 24CAB70AF0299102FD3ABBE843149A34.cache.html:16559
au() 24CAB70AF0299102FD3ABBE843149A34.cache.html:21256
_t/<() 24CAB70AF0299102FD3ABBE843149A34.cache.html:20603

~~~

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.3.1-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. go to Hosts
2. select a host, click VMs subtab
3. click between hosts

Actual results:
uncaught exception

Expected results:
ui without uncaught exception popup

Additional info:
you can check our brq-setup.xxx.xxx.xxx (ping me for details)
Comment 4 Alexander Wels 2016-02-17 08:35:48 EST
This is the part of the UI we are interested in. I hadn't noticed you included the UI.log in the bug. Which did actually contain the information I was interested in:

2016-02-11 13:00:27,079 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-15) [] Uncaught exception: : com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: d is null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.7.0_95]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.7.0_95]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.view.client.SelectionChangeEvent.fire(SelectionChangeEvent.java:67) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.table.OrderedMultiSelectionModel.$resolveChanges(OrderedMultiSelectionModel.java:117)
	at org.ovirt.engine.ui.common.widget.table.OrderedMultiSelectionModel.fireSelectionChangeEvent(OrderedMultiSelectionModel.java:110)
	at com.google.gwt.view.client.SelectionModel$AbstractSelectionModel$1.execute(SelectionModel.java:128) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl.runScheduledTasks(SchedulerImpl.java:164) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl.$flushFinallyCommands(SchedulerImpl.java:270) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.exit(Impl.java:378) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: d is null
	at org.ovirt.engine.core.common.VdcActionUtils.canExecute(VdcActionUtils.java:340) [common.jar:]
	at org.ovirt.engine.ui.webadmin.section.main.presenter.tab.host.SubTabHostGeneralInfoPresenter.$updateAlerts(SubTabHostGeneralInfoPresenter.java:125)
	at org.ovirt.engine.ui.webadmin.section.main.presenter.tab.host.SubTabHostGeneralInfoPresenter$1.$eventRaised(SubTabHostGeneralInfoPresenter.java:109)
	at org.ovirt.engine.ui.webadmin.section.main.presenter.tab.host.SubTabHostGeneralInfoPresenter$1.eventRaised(SubTabHostGeneralInfoPresenter.java:109)
	at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:114)
	at org.ovirt.engine.ui.uicommonweb.models.Model.$onPropertyChanged(Model.java:467)
	at org.ovirt.engine.ui.uicommonweb.models.hosts.HostGeneralModel.$setHasUpgradeAlert(HostGeneralModel.java:567)
	at org.ovirt.engine.ui.uicommonweb.models.hosts.HostListModel.$updateAlerts(HostListModel.java:1693)
	at org.ovirt.engine.ui.uicommonweb.models.hosts.HostListModel.$onSelectedItemChanged(HostListModel.java:1687)
	at org.ovirt.engine.ui.uicommonweb.models.hosts.HostListModel.onSelectedItemChanged(HostListModel.java:1687)
	at org.ovirt.engine.ui.uicommonweb.models.ListModel.$setSelectedItem(ListModel.java:80)
	at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel.$setSelectedItem(SearchableListModel.java:409)
	at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel.setSelectedItem(SearchableListModel.java:409)
	at org.ovirt.engine.ui.common.uicommon.model.DataBoundTabModelProvider.$setSelectedItems(DataBoundTabModelProvider.java:85)
	at org.ovirt.engine.ui.webadmin.section.main.presenter.AbstractMainTabWithDetailsPresenter$1.onSelectionChange(AbstractMainTabWithDetailsPresenter.java:53)
	at com.google.gwt.view.client.SelectionChangeEvent.dispatch(SelectionChangeEvent.java:98) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 11 more
Comment 5 Oved Ourfali 2016-02-17 11:16:36 EST
Fix is not backportable.
Is this is low severity, targeting to 4.0, and moving to MODIFIED.
Comment 6 Lukas Svaty 2016-07-26 06:55:22 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.