Bug 1306616 - puppet module tab in content view hangs after removing puppet module from repository
puppet module tab in content view hangs after removing puppet module from rep...
Status: CLOSED DUPLICATE of bug 1271000
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.6
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 08:05 EST by Stefan Nemeth
Modified: 2017-04-25 12:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 03:07:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Nemeth 2016-02-11 08:05:23 EST
Description of problem:

When you delete puppet module from puppet repository and go to the content view which is using the module webUI hangs and 500 internal server error can be found in foreman-tail when puppet modules tab is clicked

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install satellite 6.1.6
2. create product for puppet repo and upload a puppet module in that repo
3. create a content view add puppet module into it and publish it
4. delete puppet module from repo
5. go to content view and click puppet modules tab

Actual results:
can delete used module from repo

satellite webui Hangs
500 Internal Server Error

Expected results:

cant delete used puppet module/remove puppet module from all content views

webui will not hand 


Additional info:
Comment 1 Stefan Nemeth 2016-04-04 03:07:39 EDT

*** This bug has been marked as a duplicate of bug 1271000 ***

Note You need to log in before you can comment on or make changes to this bug.