Bug 1306622 - Repository sync is broken
Repository sync is broken
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
high Severity high (vote)
: Beta
: --
Assigned To: Katello Bug Bin
Brad Buckingham
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 08:12 EST by Sachin Ghai
Modified: 2016-07-27 05:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13663 None None None 2016-04-22 10:59 EDT

  None (edit)
Description Sachin Ghai 2016-02-11 08:12:30 EST
I was trying to sync custom repos and found that sync is getting failed on latest nightly..
<pre>
2016-02-11 04:16:47 [foreman-tasks/action] [E] An error occurred during the sync 
 | {"url"=>"http://example.redhat.com/released/RHEL-7/7.2/Server/x86_64/os/389-ds-base-1.3.4.0-19.el7.x86_64.rpm", "errors"=>["Not Found"]} (RuntimeError)
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/pulp/repository/sync.rb:53:in `block in check_error_details'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/pulp/repository/sync.rb:50:in `each'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/pulp/repository/sync.rb:50:in `check_error_details'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/pulp/repository/sync.rb:41:in `finalize'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/action.rb:528:in `block (2 levels) in execute_finalize'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware/stack.rb:26:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware.rb:17:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware.rb:38:in `finalize'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware/stack.rb:22:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.9/lib/dynflow/middleware.rb:17:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/middleware/remote_action.rb:20:in `block in finalize'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/middleware/remote_action.rb:40:in `block in as_remote_user'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/models/katello/concerns/user_extensions.rb:20:in `cp_config'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/middleware/remote_action.rb:27:in `as_cp_user'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/lib/actions/middleware/remote_action.rb:39:in `as_remote_user'
</pre>

I tried hammer too and found same issue

reproducible build packages:
--------------------------
tfm-rubygem-hammer_cli_foreman_tasks-0.0.9-2.fm1_11.el6.noarch
tfm-rubygem-foreman-tasks-0.7.11-1.fm1_11.el6.noarch
katello-common-2.5.0-4.nightly.el6.noarch
pulp-rpm-plugins-2.8.0-0.4.beta.el6.noarch
katello-default-ca-1.0-1.noarch
katello-repos-2.4.0-2.nightly.el6.noarch
python-isodate-0.5.0-4.pulp.el6.noarch
foreman-debug-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
createrepo-0.9.9-21.2.pulp.el6.noarch
python-pulp-bindings-2.8.0-0.4.beta.el6.noarch
python-pulp-docker-common-2.0.0-0.4.beta.el6.noarch
foreman-vmware-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-4.el6.noarch
tfm-rubygem-foreman_gutterball-0.0.1-5.el6.noarch
pulp-server-2.8.0-0.4.beta.el6.noarch
pulp-puppet-plugins-2.8.0-0.4.beta.el6.noarch
katello-certs-tools-2.4.0-1.el6.noarch
pulp-selinux-2.8.0-0.4.beta.el6.noarch
python-pulp-common-2.8.0-0.4.beta.el6.noarch
python-pulp-puppet-common-2.8.0-0.4.beta.el6.noarch
katello-service-2.5.0-4.nightly.el6.noarch
foreman-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
foreman-ovirt-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-5.el6.noarch
foreman-gce-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
foreman-libvirt-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
tfm-rubygem-katello-2.5.0-.201602051733gitb043bc51.nightly.el6.noarch
pulp-nodes-parent-2.8.0-0.4.beta.el6.noarch
katello-2.5.0-4.nightly.el6.noarch
katello-server-ca-1.0-1.noarch
foreman-postgresql-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
mod_wsgi-3.4-2.pulp.el6.x86_64
foreman-release-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
foreman-release-scl-2-1.el6.x86_64
pulp-puppet-tools-2.8.0-0.4.beta.el6.noarch
katello-installer-2.5.0-1.nightly.201602051801git5f95a31.el6.noarch
foreman-compute-1.11.0-0.develop.201602091012git5ac689f.el6.noarch
tfm-rubygem-foreman_hooks-0.3.9-2.fm1_11.el6.noarch
tfm-rubygem-foreman_docker-2.0.1-1.fm1_11.el6.noarch
python-pulp-oid_validation-2.8.0-0.4.beta.el6.noarch
pulp-nodes-common-2.8.0-0.4.beta.el6.noarch
pulp-docker-plugins-2.0.0-0.4.beta.el6.noarch
foreman-selinux-1.11.0-0.develop.201601041235git6234447.el6.noarch
rubygem-smart_proxy_pulp-1.2.0-1.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
katello-installer-base-2.5.0-1.nightly.201602051801git5f95a31.el6.noarch
python-pulp-rpm-common-2.8.0-0.4.beta.el6.noarch
tfm-rubygem-hammer_cli_foreman-0.5.1-2.201601281449git35f095e.el6.noarch
python-kombu-3.0.24-11.pulp.el6.noarch
tfm-rubygem-hammer_cli_katello-0.0.20-1.el6.noarch
python-pulp-repoauth-2.8.0-0.4.beta.el6.noarch
katello-debug-2.5.0-4.nightly.el6.noarch
pulp-katello-1.0-1.el6.noarch
foreman-proxy-1.11.0-0.develop.201601271538gite26eb4f.el6.noarch
katello-selinux-2.2.2-1.el6.noarch
Comment 1 Sachin Ghai 2016-02-11 08:12:36 EST
Created from redmine issue http://projects.theforeman.org/issues/13663
Comment 3 Bryan Kearney 2016-02-18 12:36:05 EST
Justin says this will be fixed with a new pulp. I am moving this to POST. PLease test after the 24th drop.
Comment 5 Brad Buckingham 2016-03-24 15:18:23 EDT
Successfully synced several repositories (custom and RH) on test day.  E.g. RHEL 6Server, 6.7, 7Server, 7.2, zoo...etc.
Comment 8 errata-xmlrpc 2016-07-27 05:23:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.