Bug 1306638 - Product Features for Role can be cleared
Product Features for Role can be cleared
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Dávid Halász
Ramesh A
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 09:00 EST by Krain Arnold
Modified: 2016-07-13 05:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:37:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krain Arnold 2016-02-11 09:00:59 EST
Description of problem:
If you clear all of the product features from a role, you recieve and error saying that "At least one Product Feature must be selected". If you cancel out after that, the role is saved with all the product features removed, and users with that role will not be able to log into the appliance.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Edit a role of your choice.
2. Unselect the top box "Everything"
3. Attempt to save
4. After reading the error message, cancel out of the editing process

Actual results:
The Product features list is completely cleared.

Expected results:
The cancel process would leave the role in the state it was before editing.

Additional info:
Comment 3 CFME Bot 2016-02-26 12:10:37 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1e60f11176956f62cee927136de19f27af8e32d6

commit 1e60f11176956f62cee927136de19f27af8e32d6
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Mon Feb 15 12:14:54 2016 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Fri Feb 26 16:54:36 2016 +0100

    Do not save rbac features before validating them
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306638

 app/controllers/ops_controller/ops_rbac.rb | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
Comment 5 CFME Bot 2016-02-29 09:46:23 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 6 Ramesh A 2016-04-22 09:32:48 EDT
Good to go.  Verified and working fine in 5.6.0.4-beta2.3.20160421172650_719e256
Comment 8 errata-xmlrpc 2016-06-29 11:37:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.