Bug 1306655 - Inspector packaging should create /var/log/ironic-inspector/ with appropriate ACL
Inspector packaging should create /var/log/ironic-inspector/ with appropriate...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-inspector (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
Alexander Chuzhoy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 09:21 EST by Dmitry Tantsur
Modified: 2016-04-07 17:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-ironic-inspector-2.2.4-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:47:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Tantsur 2016-02-11 09:21:17 EST
Inspector stores ramdisk logs in /var/log/ironic-inspector/ramdisk by default, so this directory (and its parent) should be present and have appropriate ACL.
Comment 2 John Trowbridge 2016-02-11 09:34:07 EST
I think we just need to cherry-pick this downstream:

https://github.com/openstack-packages/ironic-inspector/commit/c941186021c666147a6849b7c62650f0bd2f9f74
Comment 4 Alexander Chuzhoy 2016-02-23 12:47:35 EST
Verified:
Environment:
openstack-ironic-inspector-2.2.4-1.el7ost.noarch

As listed below, the directory exists and has the proper acls:

[stack@instack ~]$ ls -laZ /var/log/ironic-inspector/ramdisk
drwxr-xr-x. ironic-inspector ironic-inspector system_u:object_r:var_log_t:s0   .
drwxr-xr-x. root             root             system_u:object_r:var_log_t:s0   ..
Comment 5 Dmitry Tantsur 2016-02-26 09:31:41 EST
I'm working on the logging improvements for ironic-inspector, and it occurred to me that we need to put logs to /var/log/ironic-inspector, meaning that it should also be owned by ironic-inspector. Mike, could you check this please?
Comment 7 Dmitry Tantsur 2016-04-06 11:32:55 EDT
[stack@instack ~]$ stat /var/log/ironic-inspector/
  File: ‘/var/log/ironic-inspector/’
  Size: 4096            Blocks: 8          IO Block: 4096   directory
Device: 801h/2049d      Inode: 525767      Links: 3
Access: (0755/drwxr-xr-x)  Uid: (  995/ironic-inspector)   Gid: (  992/ironic-inspector)
[stack@instack ~]$ stat /var/log/ironic-inspector/ramdisk/
  File: ‘/var/log/ironic-inspector/ramdisk/’
  Size: 4096            Blocks: 8          IO Block: 4096   directory
Device: 801h/2049d      Inode: 525768      Links: 2
Access: (0755/drwxr-xr-x)  Uid: (  995/ironic-inspector)   Gid: (  992/ironic-inspector)
Comment 9 errata-xmlrpc 2016-04-07 17:47:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.