Bug 1306662 - qpid-cpp-0.34-7.fc24 FTBFS: 'template<class> class std::auto_ptr' is deprecated [-Werror=deprecated-declarations]
qpid-cpp-0.34-7.fc24 FTBFS: 'template<class> class std::auto_ptr' is deprecat...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
24
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Irina Boverman
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/b...
:
: 1307967 (view as bug list)
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-11 09:29 EST by Petr Pisar
Modified: 2016-11-05 11:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: qpid-cpp-0.34-7.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-05 11:25:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-02-11 09:29:25 EST
qpid-cpp-0.34-7.fc24 fails to build in F24:

[ 19%] Building CXX object src/CMakeFiles/qpidcommon.dir/qpid/sys/posix/PollableCondition.cpp.o
cd /builddir/build/BUILD/qpid-cpp-0.34/src && /usr/bin/c++   -DXQ_EFFECTIVE_BOOLEAN_VALUE_HPP -Dqpidcommon_EXPORTS -I/builddir/build/BUILD/qpid-cpp-0.34/src -I/builddir/build/BUILD/qpid-cpp-0.34/src/../include -I/usr/include/nss3 -I/usr/include/nspr4  -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic  -fvisibility-inlines-hidden -Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual -Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch -Wno-system-headers -Woverloaded-virtual -O2 -g -DNDEBUG -fPIC   -pthread -o CMakeFiles/qpidcommon.dir/qpid/sys/posix/PollableCondition.cpp.o -c /builddir/build/BUILD/qpid-cpp-0.34/src/qpid/sys/posix/PollableCondition.cpp
[...]
/builddir/build/BUILD/qpid-cpp-0.34/src/qpid/sys/posix/PollableCondition.cpp:53:10: error: 'template<class> class std::auto_ptr' is deprecated [-Werror=deprecated-declarations]
     std::auto_ptr<DispatchHandleRef> handle;
          ^~~~~~~~
In file included from /usr/include/c++/6.0.0/memory:81:0,
                 from /usr/include/boost/function/function_base.hpp:16,
                 from /usr/include/boost/function/detail/prologue.hpp:17,
                 from /usr/include/boost/function.hpp:24,
                 from /builddir/build/BUILD/qpid-cpp-0.34/src/qpid/sys/Runnable.h:24,
                 from /builddir/build/BUILD/qpid-cpp-0.34/src/qpid/sys/Poller.h:26,
                 from /builddir/build/BUILD/qpid-cpp-0.34/src/qpid/sys/PollableCondition.h:25,
                 from /builddir/build/BUILD/qpid-cpp-0.34/src/qpid/sys/posix/PollableCondition.cpp:22:
/usr/include/c++/6.0.0/bits/unique_ptr.h:49:28: note: declared here
   template<typename> class auto_ptr;
                            ^~~~~~~~
Comment 2 Jan Kurik 2016-02-24 09:30:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Petr Pisar 2016-03-11 08:25:56 EST
*** Bug 1307967 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.