Bug 1306665 - [metrics] update metrics-deployer template to use latest image versions
[metrics] update metrics-deployer template to use latest image versions
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metrics (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
chunchen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 09:37 EST by Evgheni Dereveanchin
Modified: 2016-09-29 22:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.40-1.git.0.cfb19e2.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:57:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgheni Dereveanchin 2016-02-11 09:37:19 EST
Description of problem:
As of today, OpenShift 3.1.1 is out yet metrics-deployer.yaml still references version 3.1.0

Version-Release number of selected component (if applicable):
openshift-ansible-roles-3.0.35-1.git.0.6a386dd.el7aos.noarch

/usr/share/ansible/openshift-ansible/roles/openshift_examples/files/examples/v1.1/infrastructure-templates/enterprise/metrics-deployer.yaml


How reproducible:
 always

Steps to Reproduce:
 Check IMAGE_VERSION in the file:

Actual results:
  name: IMAGE_VERSION
  value: "3.1.0"

Expected results:

Change this to the actual version matching the RPM version, or "latest" to use the newest image available

New installations always use latest images with all errata applied
Comment 2 Xia Zhao 2016-02-15 05:04:00 EST
Verified with openshift-ansible-3.0.40-1.git.22.da21865.el7aos.noarch, 
current results:
  name: IMAGE_VERSION
  value: "3.1.1"

In order for the incoming releases in future, may it be possible to change IMAGE_VERSION to latest?
Comment 3 Brenton Leanhardt 2016-02-15 08:11:33 EST
Hi Zhao Xia,

I'm a little confused when you say "Verified with openshift-ansible-3.0.40-1.git.22.da21865.el7aos.noarch".  Do you mean to say there is still a problem?

For now it wouldn't be safe to set the image version to 'latest'.  That could result in someone installing a version of metrics-deployer that isn't compatible with their environment.  We believe the 3.1.1 version is compatible with OSE 3.1.0 though.  If you are seeing a bug please include more information.
Comment 4 Xia Zhao 2016-02-15 20:55:33 EST
Hi Brenton,

I meant the current bug fix (to set IMAGE_VERSION=3.1.1) may not work in future releases, say if we will release 3.2.0, 3.x.0... in future. And now I understand that it is unsafe to set image version to 'latest', so closing this issue as fixed, and I will track the potential problem by individual bugs in the releases post 3.1.1.

Thanks,
Xia
Comment 5 Brenton Leanhardt 2016-02-16 07:06:56 EST
That makes sense.  We'll definitely want to track the real fix for this problem so feel free to create another bug for that.
Comment 7 errata-xmlrpc 2016-02-29 07:57:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311

Note You need to log in before you can comment on or make changes to this bug.