This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306667 - Newly created volume start, starting the bricks when server quorum not met
Newly created volume start, starting the bricks when server quorum not met
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Atin Mukherjee
Byreddy
: Regression, ZStream
Depends On:
Blocks: 1268895 1299184 1308402
  Show dependency treegraph
 
Reported: 2016-02-11 09:41 EST by Byreddy
Modified: 2016-09-17 12:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-1
Doc Type: Bug Fix
Doc Text:
Previously, using the force option with the 'gluster volume start' command succeeded even when server-side quorum was not met. This has been corrected so that force no longer overrides a lack of server-side quorum being met.
Story Points: ---
Clone Of:
: 1308402 (view as bug list)
Environment:
Last Closed: 2016-06-23 01:07:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2016-02-11 09:41:35 EST
Description of problem:
=======================
Had a four node cluster and created a Distributed volume using one brick and enabled the server quorum and server-quorum ratio was 90, and stopped glusterd in one of the node to achieve server quorum not met condition based on server quorum ratio set and started the volume, *it's started and bricks are online**



Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.5-19.el7rhgs

How reproducible:
=================
Every time


Steps to Reproduce:
===================
1.Have 4 node cluster (node-1..4)
2.Create a simple distributed volume using one brick
3.Enabled the server quorum 
4.Set the server quorum ration to 90
5.Stop glusterd on one of the node (eg :node-4)
6.Try to start the volume now //will start and bricks will be online

Actual results:
===============
Bricks are online when server quorum not met


Expected results:
=================
Bricks should be in offline when server quorum not met


Additional info:
Comment 3 Atin Mukherjee 2016-02-11 10:59:00 EST
Gaurav,

Could you please check this issue?

~Atin
Comment 4 Atin Mukherjee 2016-02-11 12:59:04 EST
This looks like a regression caused by http://review.gluster.org/12718
Comment 6 Byreddy 2016-02-12 00:29:11 EST
Marking this bug as Regression failed based on above details
Comment 12 Gaurav Kumar Garg 2016-02-15 00:23:42 EST
upstream patch for this bug available: http://review.gluster.org/13442
Comment 13 Atin Mukherjee 2016-02-15 00:46:55 EST
We have a crude workaround here which is as follows:

1. Disable server side quorum by gluster volume reset <volname> cluster.server-quorum-type
2. Stop the volume
3. Turn on server side quorum by gluster volume set <volname> cluster.server-quorum-type server
Comment 20 Atin Mukherjee 2016-03-22 07:58:08 EDT
The fix is now available in rhgs-3.1.3 branch, hence moving the state to Modified.
Comment 22 Byreddy 2016-04-04 03:17:10 EDT
Verified this bug using the build "glusterfs-3.7.9-1"


Repeated the reproducing steps mentioned in description section of bug, Fix is working properly, volume start is not happening when "server side quorum not met"


Moving to verified state based on above info.
Comment 25 Atin Mukherjee 2016-06-06 02:51:02 EDT
Laura,

This bug doesn't need a doc text since its a regression. Apologies for this effort waste.

Also if you see any bugs which Gaurav has worked on, raise needinfo on me instead of Satish :)

~Atin
Comment 28 errata-xmlrpc 2016-06-23 01:07:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.