Bug 1306693 - replace-brick is failing with error message "Commit failed on <host>" when server quorum not met
replace-brick is failing with error message "Commit failed on <host>" when s...
Status: NEW
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
3.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Pranith Kumar K
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 10:34 EST by Byreddy
Modified: 2017-09-01 07:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2016-02-11 10:34:43 EST
Description of problem:
=======================
Had a four node cluster, created and started a replica volume (1*2 ) and enabled the server quorum and server-quorum ratio was set to 90, and stopped glusterd in one of the node to achieve server quorum not met condition based on server quorum ratio set and tried to replace one of the brick, it's failed with error message "volume replace-brick: failed: Commit failed on <host>"


Version-Release number of selected component (if applicable):
==============================================================
glusterfs-3.7.5-19.el7rhgs.


How reproducible:
==================
Every time


Steps to Reproduce:
===================
1.Have 4 nodes (node-1..4)
2.Create a replica volume (1*2) and start it.
3.Enable the server side quorum for the volume 
4.Set the server side quorum ratio to 90
5.Stop glusterd in one of the node (eg : node-4)
6.Now check the volume status //bricks will be in offline state
7. Try to replace one of the brick with new brick //it will fail with error message "Commit failed"

Actual results:
===============
Getting commit failed error message when tried to replace a brick when server quorum not met


Expected results:
=================
Commit failed error message should not come.


Additional info:
Comment 2 Byreddy 2016-02-11 10:42:59 EST
Addition info:
==============
This issue is with replica volume type.
Comment 3 Atin Mukherjee 2016-02-11 11:08:46 EST
Assigning it to Anuradha since she mostly work in add/remove/replace brick work flows.
Comment 6 Byreddy 2016-02-12 00:37:07 EST
This issue is there from long time with replica volume type.

Note You need to log in before you can comment on or make changes to this bug.