Bug 1306701 - error "image ID '' is invalid" when trying to build Docker image
error "image ID '' is invalid" when trying to build Docker image
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: smahajan@redhat.com
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 10:51 EST by Micah Abbott
Modified: 2016-03-24 14:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 14:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Micah Abbott 2016-02-11 10:51:43 EST
Description of problem:

When trying to build a Docker images using the 'busybox' base image, the user may receive an error like "image ID '' is invalid".


Version-Release number of selected component (if applicable):

docker-1.8.2-10.el7.x86_64


How reproducible:

Sporadic.


Steps to Reproduce:
1.  Create Dockerfile that contains 'FROM busybox'
2.  docker build -t <name> <path/to/Dockerfile>


Actual results:

-bash-4.2# docker build -t busybox_httpd /root/busybox_httpd/
Sending build context to Docker daemon 2.048 kB
Step 0 : FROM busybox
image ID '' is invalid


Expected results:

-bash-4.2# docker build -t busybox_httpd /root/busybox_httpd/
Sending build context to Docker daemon 2.048 kB
Step 0 : FROM busybox
Trying to pull repository registry.access.redhat.com/busybox ... not found
Trying to pull repository docker.io/library/busybox ... latest: Pulling from library/busybox
9e77fef7a1c9: Pull complete 
964092b7f3e5: Pull complete 
library/busybox:latest: The image you are pulling has been verified. Important: image verification is a tech preview feature and should not be relied on to provide security.
Digest: sha256:c1bc9b4bffe665bf014a305cc6cf3bca0e6effeb69d681d7a208ce741dad58e0
Status: Downloaded newer image for docker.io/busybox:latest
...


Additional info:

I've observed this sporadically while testing on RHELAH.  Unfortunately, I have not been able to reliably reproduce this.

I have an Ansible playbook that attempts to build and run Docker images using a number of base images.  In the most recent attempt to run the playbook, the first image build/run was successful using the 'alpine' base image. However, the follow on build/run of 'busybox' failed.

Below are some details from the system where I last saw the issue.


-bash-4.2# atomic host status
  TIMESTAMP (UTC)         VERSION   ID             OSNAME               REFSPEC                                                        
* 2016-02-05 17:06:13     7.2.2     b1012093ef     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard     
  2015-11-10 16:11:46     7.2       ec85fba1bf     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard     

-bash-4.2# rpm -q docker
docker-1.8.2-10.el7.x86_64

-bash-4.2# cat /root/busybox_httpd/Dockerfile 
FROM busybox
MAINTAINER Micah Abbott <micah@redhat.com>

LABEL Version=1.0
LABEL RUN="docker run -d --name NAME -p 80:80 IMAGE"

ENV container docker

COPY Dockerfile /

RUN mkdir /www && echo "SUCCESS busybox_httpd" > /www/index.html

EXPOSE 80

ENTRYPOINT [ "/bin/httpd" ]
CMD [ "-f", "-h", "/www", "-p", "80" ]

-bash-4.2# docker build -t busybox_httpd /root/busybox_httpd/
Sending build context to Docker daemon 2.048 kB
Step 0 : FROM busybox
image ID '' is invalid

# journalctl -e --no-pager -u docker
...
Feb 10 16:14:45 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:14:45.310791764-05:00" level=info msg="GET /v1.20/images/json"
Feb 10 16:14:45 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:14:45.328533955-05:00" level=warning msg="couldn't load b175bcb790231169e232739bd2172bded9669c25104a9b723999c5f366ed7543 from docker.io/busybox:latest: image ID '' is invalid"
Feb 10 16:14:46 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:14:46.155999154-05:00" level=info msg="POST /v1.20/build?cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&memory=0&memswap=0&rm=1&t=busybox_httpd&ulimits=null"
Feb 10 16:17:05 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:17:05.413992484-05:00" level=info msg="GET /v1.20/images/json"
Feb 10 16:17:05 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:17:05.455594651-05:00" level=warning msg="couldn't load b175bcb790231169e232739bd2172bded9669c25104a9b723999c5f366ed7543 from docker.io/busybox:latest: image ID '' is invalid"
Feb 10 16:17:22 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:17:22.906471652-05:00" level=info msg="POST /v1.20/build?cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&memory=0&memswap=0&rm=1&t=busybox_httpd&ulimits=null"
Feb 10 16:19:55 dhcp-41-112.bos.redhat.com docker[4867]: time="2016-02-10T16:19:55.898463850-05:00" level=info msg="POST /v1.20/build?cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&memory=0&memswap=0&rm=1&t=busybox_httpd&ulimits=null"
Comment 2 Daniel Walsh 2016-02-22 14:09:22 EST
Any chance you could try to recreate this with docker-1.10?
Comment 3 Daniel Walsh 2016-02-22 14:09:40 EST
Any chance you could try to recreate this with docker-1.10?
Comment 4 Micah Abbott 2016-02-22 14:12:33 EST
I'll try to reproduce it, but no promises as it was sporadic in the first place.
Comment 5 smahajan@redhat.com 2016-03-23 10:51:44 EDT
Micah, 

Were you able to reproduce this ?

Shishir
Comment 6 Micah Abbott 2016-03-23 14:18:18 EDT
I tried a few times, never reproduced it and lost track of my efforts due to other priorities.

I'll give it one more attempt in the next day or so, but it is looking like it is not reproducible.
Comment 7 Micah Abbott 2016-03-24 14:49:12 EDT
I tried to reproduce this today on an F23 system using docker-1.10.2-9.git0f5ac89.fc23.x86_64 from Koji, but was unsuccessful.

Closing it as WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.