Bug 1306731 - RFE: Add MySQL 5.7 for supporting 4 byte characters in MySQL connections by default
RFE: Add MySQL 5.7 for supporting 4 byte characters in MySQL connections by d...
Status: CLOSED DUPLICATE of bug 1353985
Product: Red Hat Software Collections
Classification: Red Hat
Component: mysql (Show other bugs)
rh-mysql57
All Linux
unspecified Severity medium
: alpha
: 2.2
Assigned To: Jakub Dorňák
qe-baseos-daemons
: FutureFeature, Triaged
Depends On: 1353985
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 11:43 EST by Bryan Totty
Modified: 2016-08-08 09:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 09:28:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Totty 2016-02-11 11:43:40 EST
Description of problem:

Refer to the Atlassian bug report JRA-36135 (https://jira.atlassian.com/browse/JRA-36135). Even though MySQL 5.5 and MySQL 5.6 support 4-byte UTF-8 via utf8mb4 charset, the MySQL InnoDB engine limitations (767 bytes is a maximum for a indexed field) hinder its usefulness. These limitations are rectified in MySQL 5.7, which can be configured to support larger indexable fields than 767 bytes.

Due to prior versions of MySQL not correctly supporting 4-byte UTF-8 characters, MySQL 5.5 and MySQL 5.6 cannot be used as a database backend for e.g. Atlassian JIRA without running into issues that relate to 4-byte UTF-8 characters being present in user input. Usually this means that the application cannot commit data to the database when the input contains 4-byte UTF-8 characters.

There is a related Openshift BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=1186681

Version-Release number of selected component (if applicable):
Software Collections:
rh-mysql56-mysql-5.6.26-1.el6

Additional info:
Other Reference-
https://www.drupal.org/node/1314214

Note You need to log in before you can comment on or make changes to this bug.