Bug 130677 - Unable to build control-center from source on QA's stable x86_64 and s390x boxes.
Unable to build control-center from source on QA's stable x86_64 and s390x bo...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: control-center (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-23 13:53 EDT by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 17:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2004-08-23 13:53:57 EDT
Description of problem: Unable to build from source on x86_64 and
s390x boxes.


Version-Release number of selected component (if applicable):
control-center-2.2.0.1-12

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild control-center-2.2.0.1-12.src.rpm
2.
3.
  
Actual results:

gcc -O2 -g -pipe -Wall -o gnome-file-types-properties
file-types-capplet.o mime-types-model.o model-entry.o mime-type-info.o
mime-edit-dialog.o mime-category-edit-dialog.o service-info.o
service-edit-dialog.o -Wl,--export-dynamic -pthread
-Wl,--export-dynamic -pthread  -L/usr/X11R6/lib64 -lX11
../../capplets/common/.libs/libcommon.al -lglade-2.0 -lgnome-desktop-2
-lgnomeui-2 -lSM -lICE -lstartup-notification-1 -lbonoboui-2 -lxml2
-lpthread -lz -lgnomecanvas-2 -lgnome-2 -lart_lgpl_2 -lpangoft2-1.0
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0
-lpangox-1.0 -lpango-1.0 -lbonobo-2 -lgconf-2 -lgnomevfs-2
-lbonobo-activation -lORBit-2 -lm -llinc -lgmodule-2.0 -ldl
-lgobject-2.0 -lgthread-2.0 -lglib-2.0 libuuid/libuuid.a
/usr/lib/libpopt.so
/usr/lib/libpopt.so: could not read symbols: Invalid operation

Expected results:

Successful build.

Additional info:
Comment 1 Bastien Nocera 2007-02-15 06:13:01 EST
Suzanne, is this still current?
My guess is that it's a problem with the installation. Why would it try to link
against the 32-bit version of libpopt...
Comment 2 Ray Strode [halfline] 2007-02-15 10:28:38 EST
It's because of a buggy libtool shipped with the tarball.

The fix is to run libtoolize --force and autoreconf before %configure (or do in
on a local machine and patch the generated files, so we don't introduce new
build requirements).

often running

make LIBTOOL=/usr/bin/libtool 

works, too, for this kind of problem, but that's not the right solution.
Comment 4 Bastien Nocera 2007-10-15 17:18:14 EDT
I see not point in fixing this, as we ship binary packages, and it worked when
it mattered.

Note You need to log in before you can comment on or make changes to this bug.