Bug 13068 - bootnet/boot: slightly different behaviour in keyboard layout selection
Summary: bootnet/boot: slightly different behaviour in keyboard layout selection
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard: Winston rc1
Keywords:
Depends On: 12221
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-26 16:31 UTC by Pekka Savola
Modified: 2007-03-27 03:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 17:37:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-06-26 16:31:26 UTC
[ this is a copy of RH6.2 report #12221, the bug exists in betas too ]

 Using the latest updates disk and the latest boot.img/bootnet.img 
 (CDROM/FTP Server).

 Beginning the installation with 'text updates'.

 In keyboard layout selection menu, pressing 'F' yields different 
 selection in bootnet/boot.  The one goes to 'fi', the other to 
'fi-latin1'.
 Both layouts still exist in both cases, the hotkey algorithm just seems to 
 be different (or one layout is missing from one).

(verified by brock)

Comment 1 Michael Fulbright 2000-07-07 01:50:39 UTC
I could not reproduce this problem in beta3.

Comment 2 Pekka Savola 2000-07-10 15:08:21 UTC
It seems to be there still.  Did you use TUI?
The procedure I used with beta3:

1)
- Boot w/ bootnet.img on floppy, hit enter on Syslinux prompt
- Choose English as language.
- Press 'f' in keyboard layout selection --> fi-latin1.

2)
- Boot w/ redhat-shipped beta3, say 'text' in Syslinux prompt
- Choose English as language.
- Press 'f' in keyboard layout selection --> fi.

HTH.



Comment 3 Brock Organ 2000-07-10 23:11:11 UTC
verified ... the inconsistency appears to be due to a different sort order
imposed by keyboard selection in stage1 vs keyboard selection in stage2 ...

Comment 4 Erik Troan 2000-07-15 15:15:41 UTC
Fixed.

Comment 5 Pekka Savola 2000-07-27 12:06:26 UTC
Fix verified in beta4.

Comment 6 Pekka Savola 2000-08-02 11:06:05 UTC
The original selection bug was fixed in Pinstripe.

*However* now if you choose 'fi-latin1' in TUI, 'fi' will end up written in
/etc/sysconfig/keyboard and
the layout will be messed up.

Forgot to update something else too?

If this can't be fixed properly, by all means revert to the old behaviour (for
now at least). 


Comment 7 Glen Foster 2000-08-04 20:37:29 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

...a *complete* fix for GUI and TUI is requried.  Either that, or the original
behavior needs to be restored.

Comment 8 Erik Troan 2000-08-08 17:37:41 UTC
Fixed for RC1

Comment 9 Pekka Savola 2000-08-10 15:12:50 UTC
Works fine in RC1, closing.


Note You need to log in before you can comment on or make changes to this bug.