Bug 1306837 - Anaconda's help is broken
Anaconda's help is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F24FinalBlocker
  Show dependency treegraph
 
Reported: 2016-02-11 15:44 EST by Giulio 'juliuxpigface'
Modified: 2016-02-22 14:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 14:42:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 753443 None None None 2016-02-11 15:44 EST

  None (edit)
Description Giulio 'juliuxpigface' 2016-02-11 15:44:23 EST
Description of problem:
Well, as you might know, this bug has got a long story behind itself...

It has been introduced by package "yelp 3.17.3", which has been downgraded in order to fix the issue for the launch of Fedora 23. See this bug for further information, about F23:
https://bugzilla.redhat.com/show_bug.cgi?id=1276226

This November, I proposed RHBZ #1276432 as blocker, because I encountered that crash after clicking the Help button in Anaconda. As Michael Catanzaro cleared out (https://bugzilla.redhat.com/show_bug.cgi?id=1276432#c20), this was a different issue. It was a blocker for sure (since yelp was crashing on Gnome's startup), but a new problem, perhaps unrelated.

Today I verified that the issue is still present in "boot.iso" coming from the 20160210 Rawhide compose.

So.. To sum it all up... I'm opening this (and link it to the upstream report) in order to be sure that we don't forget about the broken behavior


Version-Release number of selected component (if applicable):
yelp-3.19.1-2.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run F24's Anaconda.
2. Click the "help" button.


Actual results:
Help function does not work

Expected results:
Help function must work

Additional info:
Screenshot attached: https://bugzilla.redhat.com/attachment.cgi?id=1096278
Comment 1 Fedora Blocker Bugs Application 2016-02-11 15:50:06 EST
Proposed as a Blocker for 24-final by Fedora user juliuxpigface using the blocker tracking app because:

 The previous proposed blocker (1276432) was a different issue; Anaconda's help seems to be still broken.

This is a clear violation of the "2.2.14 Installer help" Final criteria.

"Any element in the installer interface(s) which is clearly intended to display 'help' text must do so correctly when activated. "

Link: https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#installer-help
Comment 2 Petr Schindler 2016-02-15 12:57:09 EST
Discussed at 2016-02-15 blocker review meeting: [1]. 

This bug was accepted as a Final blocker: clear violation of "Any element in the installer interface(s) which is clearly intended to display 'help' text must do so correctly when activated."

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2016-02-15/f24-blocker-review.2016-02-15-17.00.html
Comment 3 Michael Catanzaro 2016-02-16 12:37:38 EST
It shooooould be fixed in yesterday's release (yelp 3.19.90) but nobody has tested this with Anaconda.
Comment 4 Martin Kolman 2016-02-22 13:04:26 EST
(In reply to Michael Catanzaro from comment #3)
> It shooooould be fixed in yesterday's release (yelp 3.19.90) but nobody has
> tested this with Anaconda.
I tried the latest nightly (has Anaconda 24.13-1 and yelp 3.19.90) and it works!  It correctly shows the help content when the help button is clicked. :)

Just two small un/related observations (& possible bug reports ?):

1) there is no close button on the yelp window
- also right-clicking the window header does nothing
2) the popup actions for the buttons on the right seem to pop-up *under* the window content
- for the first (favorites) and third (menu?) button
- the search button works fine - successfully toggles search entry under the header
Comment 5 Michael Catanzaro 2016-02-22 14:42:19 EST
(In reply to Martin Kolman from comment #4)
> I tried the latest nightly (has Anaconda 24.13-1 and yelp 3.19.90) and it
> works!  It correctly shows the help content when the help button is clicked.
> :)

Sweet

> Just two small un/related observations (& possible bug reports ?):
> 
> 1) there is no close button on the yelp window
> - also right-clicking the window header does nothing
> 2) the popup actions for the buttons on the right seem to pop-up *under* the
> window content
> - for the first (favorites) and third (menu?) button
> - the search button works fine - successfully toggles search entry under the
> header

Yes, it sounds like two different bug reports, ideally against gtk+ on GNOME Bugzilla where it is more likely to be noticed, or against gtk3 here on RBZ if you don't have a GNOME Bugzilla account or think they could be blockers (probably not).

Note You need to log in before you can comment on or make changes to this bug.