Bug 1306841 - RFE: Hardware Enablement: Intel P530 IGP for skylake Xeon processors
RFE: Hardware Enablement: Intel P530 IGP for skylake Xeon processors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
7.2
x86_64 All
high Severity high
: rc
: ---
Assigned To: Lyude
Desktop QE
: Desktop, FutureFeature, HardwareEnablement, RFE
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 16:07 EST by Joe Wright
Modified: 2017-01-12 10:25 EST (History)
32 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-02 05:05:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2193961 None None None 2016-03-09 04:13 EST

  None (edit)
Description Joe Wright 2016-02-11 16:07:15 EST
Description of problem:
- Current i915 driver does not support Intel P530 graphics included on Skylake family APUs
- http://ark.intel.com/products/88173/Intel-Xeon-Processor-E3-1245-v5-8M-Cache-3_50-GHz

Version-Release number of selected component (if applicable):
- currentrelease

How reproducible:
-100%

Steps to Reproduce:
1. None, Code review shows its not supported
2.
3.

Actual results:


Expected results:


Additional info:
Comment 10 support.linux 2016-07-01 04:59:46 EDT
High.
We don't have any news of the support for this problem which is now a high problem for us because computers are arriving in our divisions and we don't have a solution to propose.
Can you tell us if you are working on it and if we will have a solution and when.
Regards
Comment 13 Adam Jackson 2016-07-21 11:16:16 EDT
Skylake support is planned for 7.3.
Comment 19 Kodiak Firesmith 2016-10-06 17:46:15 EDT
What info do you need Lyude?
Comment 20 Lyude 2016-10-06 17:51:10 EDT
(In reply to Kodiak Firesmith from comment #19)
> What info do you need Lyude?

oh. wasn't expecting that, sorry! internal stuff happening, don't worry :)
Comment 21 Kodiak Firesmith 2016-10-06 17:56:01 EDT
OK no worries - wanted to make sure you didn't need more info from us users before the modules made it into 7.3.  Carry on :)
Comment 34 Vasiliy Sharapov 2016-10-25 18:00:18 EDT
Reproduced on RC 1.1 RHEL-7.3-20160929.5

  Verified on:
RHEL-7.3-20161019.0
xorg-x11-server-Xorg-1.17.2-22.el7.x86_64
xorg-x11-drv-intel-2.99.917-22.20151206.el7.x86_64
kernel-3.10.0-514.el7.x86_64
linux-firmware-20160830-49.git7534e19.el7.noarch
package mesa is not installed
mesa-dri-drivers-11.2.2-2.20160614.el7.x86_64
package xorg-x11-glamor is not installed

Note You need to log in before you can comment on or make changes to this bug.