Bug 1306850 - Refactor Red Hat Access Lib to be a Proxy to Restful Services on redhat.com
Refactor Red Hat Access Lib to be a Proxy to Restful Services on redhat.com
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-redhat_access_lib (Show other bugs)
Unspecified
All All
high Severity high (vote)
: Beta
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On: 1306847
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 16:47 EST by Keith Robertson
Modified: 2016-07-27 05:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: tfm-rubygem-redhat_access_lib-1.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306847
Environment:
Last Closed: 2016-07-27 05:23:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Robertson 2016-02-11 16:47:48 EST
Cloning this bug for 6.2.0

+++ This bug was initially created as a clone of Bug #1306847 +++

The REST endpoints on redhat.com that enable the Satellite 6 Red Hat Access plug-in will sunset CORS support soon.  To ensure that the Red Hat Access plug-in, continues to function in Satellite 6 all client calls must be proxied through the Satellite 6 server to REST endpoints on redhat.com.

This BZ enables this capability.  It is important to note that the proxy will *only* proxy traffic to the approved REST endpoints on RH.com and nowhere else and this proxy is only to enable the services provided the plug-in[1]

[1] https://access.redhat.com/articles/899803
Comment 4 jcallaha 2016-04-14 15:28:59 EDT
Verified in Satellite 6.2 Beta Snap 8 Compose 1. The plugin works appropriately.
Comment 8 errata-xmlrpc 2016-07-27 05:23:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.