Bug 1306894 - Directory /tmp to mount over is not empty, mounting anyway
Directory /tmp to mount over is not empty, mounting anyway
Status: CLOSED DUPLICATE of bug 1306452
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 22:35 EST by Chris Murphy
Modified: 2016-02-12 05:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 05:40:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2016-02-11 22:35:17 EST
Description of problem:

Looks like anaconda writes out files to /tmp in the chrooted installation environment, which doesn't use tmpfs on /tmp. So these files are in /tmp on disk, and then when systemd mounts tmpfs on /tmp it complains that it's not empty.


Version-Release number of selected component (if applicable):
anaconda 23.19.10-1

How reproducible:
Always


Steps to Reproduce:
1. Do an installation
2. Reboot
3.

Actual results:

Feb 11 19:48:10 f23s.localdomain systemd[1]: tmp.mount: Directory /tmp to mount over is not empty, mounting anyway.

Looking at actual /tmp without tmpfs mounted over it:
$ ls -l /mnt/tmp
total 4
drwxr-xr-x. 2 root root  19 Feb  6 04:59 hsperfdata_root
-rwx------. 1 root root 852 Feb 11 11:49 ks-script-bytw8xx2

And also:
$ grep ks-script /var/log/anaconda/program.log  
11:49:49,769 INFO program: Running... /bin/sh /tmp/ks-script-bytw8xx2
11:49:53,161 INFO program: Running... /bin/sh /tmp/ks-script-hy66_vxy
11:49:53,186 INFO program: Running... /bin/sh /tmp/ks-script-iqzupo_o



Expected results:

I don't know if these ks files have any long term importance, if they do they probably should get written to /var/log/anaconda rather than either live tmpfs on /tmp, or chrooted enviro's root fs /tmp. Or use /var/tmp I guess, but not /tmp.

Additional info:
Comment 1 Martin Kolman 2016-02-12 05:40:18 EST

*** This bug has been marked as a duplicate of bug 1306452 ***

Note You need to log in before you can comment on or make changes to this bug.