This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306897 - Remove split-brain-healing.t from bad tests
Remove split-brain-healing.t from bad tests
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 23:34 EST by Pranith Kumar K
Modified: 2016-06-16 09:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:57:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-02-11 23:34:50 EST
Description of problem:
Ran the test in a loop for more than an hour but no failures are seen. Moving it back to normal tests for now.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-11 23:35:57 EST
REVIEW: http://review.gluster.org/13434 (Remove split-brain-healing.t from bad-tests) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-06 23:03:30 EST
REVIEW: http://review.gluster.org/13434 (Remove split-brain-healing.t from bad-tests) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-03-15 03:03:00 EDT
REVIEW: http://review.gluster.org/13434 (tests: Self-heald.t spurious failure fix) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2016-03-15 11:28:52 EDT
REVIEW: http://review.gluster.org/13434 (tests: Self-heald.t spurious failure fix) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-03-17 02:13:32 EDT
COMMIT: http://review.gluster.org/13434 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fb3d300617d3616e1b901dd5503ff330a542c7be
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Mar 15 11:58:44 2016 +0530

    tests: Self-heald.t spurious failure fix
    
    Problem:
    There is no guarantee that the indices are created by the time
    write is complete because write-behind may not flush the buffers.
    
    Fix:
    Disable flush-behind so that by the time 'echo abc > file' completes,
    indices are created.
    
    Also removed split-brain-healing.t from spurious failures as we are
    not able to recreate it.
    
    BUG: 1306897
    Change-Id: I5c9c735430f1736747c8d7396d2cbf487533f4b5
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13434
    Reviewed-by: Anuradha Talur <atalur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Niels de Vos 2016-06-16 09:57:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.