Bug 1306911 - heketi: Daemon file not compiled with RELRO or PIE: /usr/bin/heketi
heketi: Daemon file not compiled with RELRO or PIE: /usr/bin/heketi
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Luis Pabón
Anush Shetty
: ZStream
Depends On:
Blocks: 1117266
  Show dependency treegraph
 
Reported: 2016-02-12 02:35 EST by Shruti Sampat
Modified: 2016-11-08 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 00:07:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2016-02-12 02:35:02 EST
Description of problem:
-----------------------

•DaemonMissingRELRO [?]
 	Daemon file not compiled with RELRO or PIE: /usr/bin/heketi

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
heketi-1.0.2-1.el6rhs

How reproducible:
-----------------
100%

Steps to Reproduce:
-------------------
1. Check build options

Actual results:
---------------
Daemon file not compiled with RELRO or PIE.

Expected results:
-----------------
Daemon files should be compiled with RELRO or PIE.
Comment 4 Siddharth Sharma 2016-02-16 00:07:44 EST
heketi is written in go and currently there seems to be no way that golang compiler would build this with RELRO/PIE flags as GCC would do for C/C++ source code. So technically at this point we can override this test and if in future we find some way to build this with RELRO/PIE we would look into it. I am closing this bug it is not blocker for this time.

Note You need to log in before you can comment on or make changes to this bug.