Bug 1306921 - aarch64 kernel is FTBFS on aarch64 due to gcc6
aarch64 kernel is FTBFS on aarch64 due to gcc6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
aarch64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2016-02-12 03:16 EST by Peter Robinson
Modified: 2016-02-12 17:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 17:35:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2016-02-12 03:16:57 EST
The aarch64 kernel is failing to build due to some issues with gcc 6

Upstream thread discussion is here:

https://gcc.gnu.org/ml/gcc-patches/2016-02/msg00313.html

Final patch for the thread looks to be here:

https://gcc.gnu.org/ml/gcc-patches/2016-02/msg00758.html

This is causing a lot of issues on the mass rebuild. Please review and add relevant patch to Fedora's gcc6 builds
Comment 1 Jeff Law 2016-02-12 03:22:15 EST
FWIW, that patch was installed into the GCC sources today, so it'll be in the next GCC spin for Fedora 24 from Jakub.
Comment 2 Marcin Juszkiewicz 2016-02-12 05:50:40 EST
https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=233342 is what got merged into gcc trunk.

I rebuilt gcc with it yesterday and kernel build goes fine with it.
Comment 3 Peter Robinson 2016-02-12 17:35:22 EST
fixed, awesome thanks Jeff/Jakub

Note You need to log in before you can comment on or make changes to this bug.