Bug 1306932 - missing depencies on erlang-erts and openstack-neutron-common
missing depencies on erlang-erts and openstack-neutron-common
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: erlang (Show other bugs)
6.0 (Juno)
x86_64 Linux
medium Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Peter Lemenkov
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 03:45 EST by GE Scott Knauss
Modified: 2016-04-18 03:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: erlang-R16B-03.10min.7.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL 7 RHOSP 6
Last Closed: 2016-04-07 17:28:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GE Scott Knauss 2016-02-12 03:45:20 EST
What problem/issue/behavior are you having trouble with?  What do you expect to see?

root@localhost ~]# grep -B2 "command not found"  /var/log/anaconda/packaging.log 
11:26:06,393 INFO packaging: erlang-erts-R16B-03.10min.2.el7ost.x86_64 (709/1196)

11:26:06,393 INFO packaging: /var/tmp/rpm-tmp.DW2cV6: line 1: groupadd: command not found
--
11:26:06,396 INFO packaging: openstack-neutron-common-2015.1.2-6.el7ost.noarch (735/1196)

11:26:06,396 INFO packaging: /var/tmp/rpm-tmp.PvbtLE: line 1: groupadd: command not found

11:26:06,396 INFO packaging: /var/tmp/rpm-tmp.PvbtLE: line 3: useradd: command not found

Where are you experiencing the behavior?  What environment?

Installing openstack rpms on kickstart install.

When does the behavior occur? Frequently?  Repeatedly?   At certain times?

always

Expected results:

successful install


Additional info:
Comment 5 Peter Lemenkov 2016-02-19 04:40:37 EST
(In reply to GE Scott Knauss from comment #0)
> What problem/issue/behavior are you having trouble with?  What do you expect
> to see?
> 
> root@localhost ~]# grep -B2 "command not found" 
> /var/log/anaconda/packaging.log 
> 11:26:06,393 INFO packaging: erlang-erts-R16B-03.10min.2.el7ost.x86_64
> (709/1196)
> 
> 11:26:06,393 INFO packaging: /var/tmp/rpm-tmp.DW2cV6: line 1: groupadd:
> command not found
> --
> 11:26:06,396 INFO packaging:
> openstack-neutron-common-2015.1.2-6.el7ost.noarch (735/1196)
> 
> 11:26:06,396 INFO packaging: /var/tmp/rpm-tmp.PvbtLE: line 1: groupadd:
> command not found
> 
> 11:26:06,396 INFO packaging: /var/tmp/rpm-tmp.PvbtLE: line 3: useradd:
> command not found

Short summary:

A sub-package erlang-erts has missing dependency (for proper execution of a %pre target script) - shadow-uting. It crreates a system account which is required epmd systemd service.

We don't use epmd as a systemd service so it should not affect normal operation after installation.
Comment 6 Peter Lemenkov 2016-02-20 15:51:08 EST
I've build a new Erlang version and submitted it to RHOS8.

it's not necessary to upgrade existing RHOS6 / RHOS7 installation up to this Erlanb build since the issue doesn't affect normal OpenStack operation (only installation).
Comment 11 nlevinki 2016-04-06 03:43:56 EDT
rpm -qa | grep erlang
erlang-sasl-R16B-03.10min.8.el7ost.x86_64
erlang-inets-R16B-03.10min.8.el7ost.x86_64
erlang-mnesia-R16B-03.10min.8.el7ost.x86_64
erlang-asn1-R16B-03.10min.8.el7ost.x86_64
erlang-stdlib-R16B-03.10min.8.el7ost.x86_64
erlang-runtime_tools-R16B-03.10min.8.el7ost.x86_64
erlang-os_mon-R16B-03.10min.8.el7ost.x86_64
erlang-public_key-R16B-03.10min.8.el7ost.x86_64
erlang-hipe-R16B-03.10min.8.el7ost.x86_64
erlang-kernel-R16B-03.10min.8.el7ost.x86_64
erlang-snmp-R16B-03.10min.8.el7ost.x86_64
erlang-sd_notify-0.1-2.el7ost.x86_64
erlang-ssl-R16B-03.10min.8.el7ost.x86_64
erlang-compiler-R16B-03.10min.8.el7ost.x86_64
erlang-erts-R16B-03.10min.8.el7ost.x86_64
erlang-xmerl-R16B-03.10min.8.el7ost.x86_64
erlang-tools-R16B-03.10min.8.el7ost.x86_64
erlang-crypto-R16B-03.10min.8.el7ost.x86_64
erlang-otp_mibs-R16B-03.10min.8.el7ost.x86_64
erlang-syntax_tools-R16B-03.10min.8.el7ost.x86_64
Comment 12 errata-xmlrpc 2016-04-07 17:28:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.