Bug 1306980 - amanda-3.3.3-13.el7.x86_64 fails to correctly handle compressed archive
amanda-3.3.3-13.el7.x86_64 fails to correctly handle compressed archive
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: amanda (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Josef Ridky
Daniel Rusek
: Patch
Depends On: 1299761
Blocks: 1400961 1472751 1380364 1393870 1465906 1465925
  Show dependency treegraph
 
Reported: 2016-02-12 05:53 EST by Presian Yankulov
Modified: 2018-04-10 04:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: amanda-3.3.3-19.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 04:53:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0674 None None None 2018-04-10 04:54 EDT

  None (edit)
Description Presian Yankulov 2016-02-12 05:53:34 EST
Description of problem:

Older server always do the decompression. 

In newer version (3.3.x), server compression is decompressed on the 
server and client compression is decompressed on the client. 

This bug is fixed in 3.3.6

Version-Release number of selected component (if applicable):
	Server:
CentOS release 6.7 (Final)
amanda-2.6.1p2-9.el6_6.x86_64
amanda-client-2.6.1p2-9.el6_6.x86_64
amanda-server-2.6.1p2-9.el6_6.x86_64

Client:
CentOS Linux release 7.2.1511 (Core)
amanda-libs-3.3.3-13.el7.x86_64
amanda-client-3.3.3-13.el7.x86_64
amanda-3.3.3-13.el7.x86_64

How reproducible:
Connect to the Server from the Client with amrecover and add file to extract:


Added file /adduser.conf 
amrecover> extract 
[...] 
Restoring files into directory /tmp/tmp.JwS8LFGzAS 
All existing files in /tmp/tmp.JwS8LFGzAS can be deleted 
Continue [?/Y/n]? y 

tar: This does not look like a tar archive 
tar: ./adduser.conf: Not found in archive 
[...] 
tar: ./xml: Not found in archive 
tar: Exiting with failure status due to previous errors 


Steps to Reproduce:
1.
2.
3.

Actual results:
And amrecover hangs, but can be interrupted with CTRL-C. 

Expected results:
amrecover should proceed as normal and extract the archive to the client side.

Additional info:
same bug is reported:
http://archives.zmanda.com/amanda-archives/viewtopic.php?t=7322&sid=31bf5a8d21db35ad0e4fffeb511403d9
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=687312.
Comment 1 Presian Yankulov 2016-02-12 05:56:02 EST
Older server always do the decompression. 

In newer version (3.3.x), server compression is decompressed on the 
server and client compression is decompressed on the client. 

This bug is fixed in 3.3.6
Comment 3 Josef Ridky 2016-10-04 04:17:27 EDT
Thank you for taking the time to report this issue to us. We appreciate the feedback and use reports such as this one to guide our efforts at improving our products. Please keep in mind for future, that this bug tracking system is not a mechanism for requesting support, and we are not able to guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through the regular Red Hat support channels to ensure it receives the proper attention and prioritization to assure a timely resolution. 

For information on how to contact the Red Hat production support team, please visit:
    https://www.redhat.com/support/process/production/#howto
Comment 8 Tereza Cerna 2017-06-23 03:51:41 EDT
I am not able to test this bug because other bug (BZ#1299761) is not fixed in RHEL-7.4 and its change is necessary for this bug.
Comment 15 errata-xmlrpc 2018-04-10 04:53:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0674

Note You need to log in before you can comment on or make changes to this bug.