Bug 1306987 - Don't work click middle button on touchpad in gnome 3
Don't work click middle button on touchpad in gnome 3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 06:31 EST by alsoijw
Modified: 2016-03-07 09:30 EST (History)
9 users (show)

See Also:
Fixed In Version: kernel-4.3.6-201.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 09:30:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xinput list-props (2.35 KB, text/plain)
2016-02-15 10:00 EST, alsoijw
no flags Details
evemu-record (2.97 KB, text/plain)
2016-02-15 10:01 EST, alsoijw
no flags Details
evemu-record log (3.33 KB, text/plain)
2016-02-15 10:08 EST, alsoijw
no flags Details

  None (edit)
Description alsoijw 2016-02-12 06:31:31 EST
Description of problem:
Don't work click middle button, if I touch touch pad three fingers.

Version-Release number of selected component (if applicable):
libinput-1.1.6-1.fc23.x86_64
Comment 1 Peter Hutterer 2016-02-14 20:32:26 EST
do you have tapping enabled? please post the output of xinput list-props <your device>

If you have it enabled, please also attach the output from sudo evemu-record when you do a three-finger tap gesture.
Comment 2 alsoijw 2016-02-15 10:00 EST
Created attachment 1127313 [details]
xinput list-props
Comment 3 alsoijw 2016-02-15 10:01 EST
Created attachment 1127314 [details]
evemu-record
Comment 4 alsoijw 2016-02-15 10:03:21 EST
Of course I enable click on touch. Only middle click don't work. I added the logs in attachments.
Comment 5 alsoijw 2016-02-15 10:08 EST
Created attachment 1127316 [details]
evemu-record log
Comment 6 Peter Hutterer 2016-02-16 02:16:35 EST
looks like https://bugs.freedesktop.org/show_bug.cgi?id=93583, so it's missing the kernel patch: https://lkml.org/lkml/2016/1/11/171

Benjamin, is this patch on the track for fedora?
Comment 7 Benjamin Tissoires 2016-02-16 04:17:52 EST
(In reply to Peter Hutterer from comment #6)
> looks like https://bugs.freedesktop.org/show_bug.cgi?id=93583, so it's
> missing the kernel patch: https://lkml.org/lkml/2016/1/11/171
> 
> Benjamin, is this patch on the track for fedora?

Unfortunately, no. I have asked it to be backported in stable too, but it looks like only 4.2, 4.1, 3.19, 3.18, 3.16, and 3.13 already included it, so it's not in our current 4.3 nor 4.4.

I'll ask someone from the fedora kernel team to take it while upstream grabs it.
Comment 8 Josh Boyer 2016-02-16 12:31:38 EST
I've added the patch in question.  It will be in the next kernel build we do.
Comment 9 Fedora Update System 2016-02-23 07:19:16 EST
kernel-4.3.6-201.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e7162262b0
Comment 10 Fedora Update System 2016-02-23 08:32:01 EST
kernel-4.4.2-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ec8b4ce774
Comment 11 Fedora Update System 2016-02-23 16:25:54 EST
kernel-4.3.6-201.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e7162262b0
Comment 12 Fedora Update System 2016-02-24 12:20:43 EST
kernel-4.4.2-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7e12ae5359
Comment 13 Fedora Update System 2016-02-25 21:24:31 EST
kernel-4.4.2-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7e12ae5359
Comment 14 Fedora Update System 2016-02-26 23:59:40 EST
kernel-4.4.3-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5ac00e07c
Comment 15 Fedora Update System 2016-02-28 03:20:25 EST
kernel-4.3.6-201.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-02-28 07:21:22 EST
kernel-4.4.2-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-02-28 08:52:22 EST
kernel-4.4.3-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a5ac00e07c
Comment 18 alsoijw 2016-02-28 16:41:34 EST
Bug fixed.
Comment 19 Fedora Update System 2016-03-01 14:14:23 EST
kernel-4.4.3-201.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9fbe2c258b
Comment 20 Fedora Update System 2016-03-01 22:28:55 EST
kernel-4.4.3-201.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9fbe2c258b
Comment 21 alsoijw 2016-03-04 15:06:16 EST
I using Fedora 23 so I can't speak about 22. I don't know why but sometimes it doesn't work. If I try this again it will be working.
Comment 22 Fedora Update System 2016-03-04 20:19:30 EST
kernel-4.4.3-201.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.