Bug 1307019 - Cannot collect logs from server to subfolder anonymous ftp
Cannot collect logs from server to subfolder anonymous ftp
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Yuri Rudman
Kyrylo Zvyagintsev
appliance:depot:maintenance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 08:13 EST by Kyrylo Zvyagintsev
Modified: 2016-06-29 11:41 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:41:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Joe Rafaniello 2016-02-12 10:31:06 EST
Hi Kyrylo, can you provide your ftp session log where it works?

In your ftp session, did you cd to the pub directly before you put the file?
Can you try 'put pub/some_file' instead of cd'ing to the directory first?

Can you also try turning on logging with log_ftp_protocol=YES and xferlog_enable=YES. Then try log collection again and provide the /var/log/vsftpd.log along with the whole evm.log containing the log collection time period?

thanks!
Comment 3 Kyrylo Zvyagintsev 2016-02-16 12:51:08 EST
Hello Joe 
Something like 'put zztest.txt pub/zztest.txt' also works for me
Comment 5 Joe Rafaniello 2016-02-17 14:18:01 EST
From the logs:

Tue Feb 16 12:44:00 2016 [pid 8051] [ftp] FAIL UPLOAD: Client "::ffff:IP_ADDRESS", "/incoming/Current_region_0_default_1_EVM_1_20160216_031907_20160216_124336.zip", 0.00Kbyte/sec

It looks like we're prepending the /incoming directory for ftp anonymous instead of specifically for the redhat customer ftp model.
Comment 7 CFME Bot 2016-02-24 16:54:42 EST
New commit detected on cfme_productization/master:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme_productization.git;a=commit;h=094c5753d02c7b685cde76be575c8ee6398d61b5

commit 094c5753d02c7b685cde76be575c8ee6398d61b5
Author:     Yuri Rudman <yrudman@redhat.com>
AuthorDate: Fri Feb 19 16:33:20 2016 -0500
Commit:     Yuri Rudman <yrudman@redhat.com>
CommitDate: Wed Feb 24 13:52:04 2016 -0500

    Moved specific limitations  for Redhat ftp dropbox from FileDepotFtpAnonymous to FileDepotFtpAnonymousRedhatDropbox
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1307019

 .../models/file_depot_ftp_anonymous_redhat_dropbox.rb    | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
Comment 8 CFME Bot 2016-03-01 17:20:40 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2315c1e7b86becc5259e5a906144184218d583c6

commit 2315c1e7b86becc5259e5a906144184218d583c6
Author:     Yuri Rudman <yrudman@redhat.com>
AuthorDate: Fri Feb 19 16:23:54 2016 -0500
Commit:     Yuri Rudman <yrudman@redhat.com>
CommitDate: Tue Mar 1 14:47:53 2016 -0500

    removed incoming as default destination folder for anonymous ftp
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1307019

 app/models/file_depot_ftp_anonymous.rb       | 18 ++----------------
 spec/models/file_depot_ftp_anonymous_spec.rb | 13 +++++++++++++
 2 files changed, 15 insertions(+), 16 deletions(-)
 create mode 100644 spec/models/file_depot_ftp_anonymous_spec.rb
Comment 9 Yuri Rudman 2016-03-02 14:05:49 EST
PR: #6829
Comment 12 errata-xmlrpc 2016-06-29 11:41:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.