Bug 1307030 - uncaught exception while searching using a tag
Summary: uncaught exception while searching using a tag
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 3.6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ovirt-3.6.5
: 3.6.5
Assignee: Alexander Wels
QA Contact: Karolína Hajná
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-12 13:55 UTC by Karolína Hajná
Modified: 2016-05-20 01:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-21 14:40:24 UTC
oVirt Team: UX
oourfali: ovirt-3.6.z?
rule-engine: ovirt-4.0.0+
rule-engine: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
ui.log (20.53 KB, text/plain)
2016-02-12 13:55 UTC, Karolína Hajná
no flags Details
ui.log (28.54 KB, text/plain)
2016-02-18 10:30 UTC, Karolína Hajná
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 54188 master MERGED webadmin: Tag selection exception 2016-02-29 21:39:04 UTC
oVirt gerrit 54213 ovirt-engine-3.6 MERGED webadmin: Tag selection exception 2016-03-01 14:27:56 UTC

Description Karolína Hajná 2016-02-12 13:55:49 UTC
Created attachment 1123509 [details]
ui.log

Description of problem:
When using a tag for search, there is an uncaught exception.

2016-02-12 14:31:53,334 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-10) [] Permutation name: 9427A308A8D941A090BA85F4C59BC529
2016-02-12 14:31:53,335 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-10) [] Uncaught exception: : com.google.gwt.core.client.JavaScriptException: (TypeError)
 __gwt$exception: <skipped>: a is undefined
        at Unknown.IFe(Unknown Source)
        at Unknown.Yto(Unknown Source)
        at Unknown.iuo(Unknown Source)
        at Unknown.Uqo(Unknown Source)
        at Unknown.XQk(Unknown Source)
        at Unknown.nds(Unknown Source)
        at Unknown.uds(Unknown Source)
        at Unknown.Gyf(Unknown Source)
        at Unknown.Kyf(Unknown Source)
        at Unknown.Kzf(Unknown Source)
        at Unknown.ZBk(Unknown Source)
        at Unknown.aCk(Unknown Source)
        at Unknown.TFf(Unknown Source)
        at Unknown.Ju(Unknown Source)
        at Unknown.Au(Unknown Source)
        at Unknown.Nu(Unknown Source)
        at Unknown.Hu(Unknown Source)
        at Unknown.Yt(Unknown Source)
        at Unknown.au(Unknown Source)
        at Unknown._t/<(Unknown Source)
        at Unknown.Ku/<(Unknown Source)
        at Unknown.kv/d<(Unknown Source)
        at Unknown.anonymous(Unknown Source)


Version-Release number of selected component (if applicable):
3.6.3

How reproducible:
100%

Steps to Reproduce:
1. Create a new tag and assign it to a host
2. In system menu on left side click on System
3. Go to tags menu and click on the icon next to your tag to use it for search
4. Try to switch between VMs and Hosts tab tabs few times

Actual results:
uncaught exception

Expected results:
exception correctly handled

Comment 1 Oved Ourfali 2016-02-16 12:03:03 UTC
Please go over the steps in:
http://www.ovirt.org/OVirt_Engine_Debug_Obfuscated_UI

And re-attach the ui.log after reproducing.

Thanks!

Comment 2 Karolína Hajná 2016-02-18 10:30:53 UTC
Created attachment 1128182 [details]
ui.log

I followed the provided steps but exception ui.log still looks the same.

Comment 3 Alexander Wels 2016-02-18 18:52:47 UTC
Karolína did you restart the engine after installing the debug information?

Comment 4 Alexander Wels 2016-02-18 19:39:40 UTC
Can I get the exact version of your RHEV? You can look it up in the about dialog.

I was able to reproduce in 3.6.2, but not in 3.6.3-2 or master. I am also guessing you have one single host, which will cause the host sub tabs to load automatically, and there is a known issue that was causing an exception that got fixed between 3.6.2 and 3.6.3-2.

Comment 5 Karolína Hajná 2016-02-19 12:16:02 UTC
(In reply to Alexander Wels from comment #3)
> Karolína did you restart the engine after installing the debug information?

restarting the engine helped. Log after restart:

2016-02-19 13:02:59,255 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-10) [] Permutation name: 9427A308A8D941A090BA85F4C59BC529
2016-02-19 13:02:59,257 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-10) [] Uncaught exception: : com.google.gwt.core.client.JavaScriptException: (TypeError)
 __gwt$exception: <skipped>: a is undefined
        at com.google.gwt.regexp.shared.RegExp.$replace(RegExp.java:127) [gwt-servlet.jar:]
        at org.ovirt.engine.ui.uicommonweb.models.CommonModel.$splitSearchString(CommonModel.java:741)
        at org.ovirt.engine.ui.uicommonweb.models.CommonModel.onSelectedItemChanged(CommonModel.java:652)
        at org.ovirt.engine.ui.uicommonweb.models.ListModel.$setSelectedItem(ListModel.java:80)
        at org.ovirt.engine.ui.common.uicommon.model.MainTabModelProvider.onMainTabSelected(MainTabModelProvider.java:31)
        at org.ovirt.engine.ui.webadmin.section.main.presenter.AbstractMainTabWithDetailsPresenter.$onReveal(AbstractMainTabWithDetailsPresenter.java:83)
        at org.ovirt.engine.ui.webadmin.section.main.presenter.AbstractMainTabWithDetailsPresenter.onReveal(AbstractMainTabWithDetailsPresenter.java:83)
        at com.gwtplatform.mvp.client.PresenterWidget.$internalReveal(PresenterWidget.java:548)
        at com.gwtplatform.mvp.client.PresenterWidget.$setInSlot(PresenterWidget.java:344)
        at com.gwtplatform.mvp.client.TabContainerPresenter.$setInSlot(TabContainerPresenter.java:212)
        at org.ovirt.engine.ui.common.presenter.DynamicTabContainerPresenter.$setInSlot(DynamicTabContainerPresenter.java:66)
        at org.ovirt.engine.ui.common.presenter.DynamicTabContainerPresenter.setInSlot(DynamicTabContainerPresenter.java:66)
        at com.gwtplatform.mvp.client.proxy.RevealContentHandler$1$1.execute(RevealContentHandler.java:63)
        at com.google.gwt.core.client.impl.SchedulerImpl.runScheduledTasks(SchedulerImpl.java:164) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.SchedulerImpl.$flushPostEventPumpCommands(SchedulerImpl.java:336) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.SchedulerImpl$Flusher.execute(SchedulerImpl.java:76) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.SchedulerImpl.execute(SchedulerImpl.java:137) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown._t/<(Unknown Source)
        at Unknown.Ku/<(Unknown Source)
        at Unknown.kv/d<(Unknown Source)
        at Unknown.anonymous(Unknown Source)

(In reply to Alexander Wels from comment #4)
> Can I get the exact version of your RHEV? You can look it up in the about
> dialog.
> 
> I was able to reproduce in 3.6.2, but not in 3.6.3-2 or master. I am also
> guessing you have one single host, which will cause the host sub tabs to
> load automatically, and there is a known issue that was causing an exception
> that got fixed between 3.6.2 and 3.6.3-2.

I have 3.6.3-0.1.el6 and a single host, yes. However, the host tab is not  necessarily selected automatically.If I  select other tab than hosts before executing the search, VMs tab is loaded in results.

Comment 6 Alexander Wels 2016-02-29 18:01:59 UTC
I have tried reproducing on the exact version you mentioned and I am unable to do so. Can you make a video of you doing what you are doing? Or give more detailed steps? I *think* I did the same thing you did but since you can make it happen and I cannot there must be something different.

Comment 7 Alexander Wels 2016-02-29 20:02:27 UTC
Nevermind, I managed to reproduce it in the 3.6.3 setup I have. I will be posting a fix shortly.

Comment 8 Karolína Hajná 2016-03-31 14:41:11 UTC
Verified in rhevm-3.6.5-0.1.el6.noarch (build 3.6.5-1)


Note You need to log in before you can comment on or make changes to this bug.