Bug 1307036 - [RFE] Auto attach VDC subscription to ESXi hypervisor
[RFE] Auto attach VDC subscription to ESXi hypervisor
Status: CLOSED DUPLICATE of bug 1308544
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Registration (Show other bugs)
6.1.6
x86_64 Linux
medium Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: FutureFeature, PrioBumpPM
Depends On:
Blocks: 1296845 1353215
  Show dependency treegraph
 
Reported: 2016-02-12 09:20 EST by Marcel Gazdík
Modified: 2017-06-19 10:46 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 12:27:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Gazdík 2016-02-12 09:20:37 EST
Description of problem:
  Support for auto attach functionality for ESXi hypervisors in virt-who environment. The VDC subscription must be attached manually to each hypervisor
reported by the virt-who. This is turning into very difficult task in environments with hundreds of hypervisors.

Version-Release number of selected component (if applicable):
Satellite 6.X


Actual results:
  Each ESXi HV has to be subscribed manually.

Expected results:
  VDC subscription will be attached automatically

Additional info:
  Current workaround is using API which is very slow.
Comment 2 Tom McKay 2016-02-12 11:13:44 EST
The following behavior is expected to work...

1. Don't assign a VDC to a hypervisor
2. Guest registers and then subscribes with --auto-attach
3. If the guest...
   a) ...has not been reported by virt-who yet, it will get a temporary guest subscription
   b) ...has been reported by virt-who, it will trigger an auto-attach on they parent hypervisor (which will grab a VDC) and then guest will get permanent guest subscription

If this is not acceptable or causing problems, please expand on the issues involved for this RFE.
Comment 3 Evgeni Golov 2016-02-12 11:28:37 EST
Hi Tom,

is there any way to select which VDC pool will be used?

We have different subs in the account that allow guests:
* Unlimited guests (1-2 sockets)
* Unlimited guests (4 sockets)
* Unlimited guests (8 sockets)
* Same as above but for 1 guest

Additionally we have them in multiple batches, bought at different times, expiring at different times.

As far as I know virt-who will not report socket-count for ESXi hypervisors.
Will 3b) then just grab any available 1-2 sockets, unlimited guests sub?

Regards
Evgeni
Comment 7 Preetesh Sharma 2016-06-19 23:22:12 EDT
Customer is requesting for an workaround on this issue.

Is below workaround applicable to this problem ?
https://github.com/RedHatSatellite/katello-attach-subscription

Also kindly empathize that #comment 3.
Comment 9 Preetesh Sharma 2016-06-23 07:15:45 EDT
Customer has also requested for the possibility to select the subscription based on (regexp)regular expression or some other method? 
preferred list: 
1) regexp on VCenter cluster name 
2) regexp on ESXi Host name"

So that they can filer based on the *Cluster* name (not hostname) in the VCenter.

Preetesh
Comment 10 Evgeni Golov 2016-06-24 03:24:55 EDT
(In reply to Preetesh Sharma from comment #9)
> Customer has also requested for the possibility to select the subscription
> based on (regexp)regular expression or some other method? 
> preferred list: 
> 1) regexp on VCenter cluster name 

That data is not available at the moment :(

> 2) regexp on ESXi Host name"

That works in katello-attache-subscription today, but yeah would be great if that would be inside Satellite.
Comment 11 Bryan Kearney 2017-06-15 12:27:34 EDT

*** This bug has been marked as a duplicate of bug 1308544 ***

Note You need to log in before you can comment on or make changes to this bug.