Bug 130705 - ccsd fails to send cluster.conf file to node requesting config
ccsd fails to send cluster.conf file to node requesting config
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-23 16:40 EDT by AJ Lewis
Modified: 2009-04-16 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 10:30:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description AJ Lewis 2004-08-23 16:40:08 EDT
Description of problem:
If a node doesn't have a cluster.conf file, trying to connect to ccsd
with a specific cluster name fails to retrieve the cluster.conf from
another running node.

If the connect is tried again, the file is retrieved.

Version-Release number of selected component (if applicable):
current cluster-project cvs

How reproducible:
Always

Steps to Reproduce:
1. Create valid /etc/cluster/cluster.conf on one node
2. Start ccsd on that node
3. Start ccsd on a new node that has /etc/cluster but not
/etc/cluster/cluster.conf
4. run 'ccs_test connect force <clustername>' on second node
5. rerun step 4
    
Alternately, replace 'ccs_test connect force <clustername>' with
'cman_tool join -c <clustername>' after modprobing the cman module.

Actual Results:  After step 4, I get this:
Force is set.
Setting cluster name to clu
ccs_connect failed: No data available

After step 5, I get this:
Force is set.
Setting cluster name to clu
Connect successful.
 Connection descriptor = 0


Expected Results:  The results of step 5 in step 4

Additional info:

I ran ethereal on the first node, and the request is definitely
getting to that node.  You can filter on a udp packet on dest port
50007.  For some reason ccsd just doesn't see it the first time.
Comment 1 Jonathan Earl Brassow 2004-09-02 16:03:13 EDT
With the recent changes to add multicast and IPv6 support, I haven't
seen this.

Please confirm.
Comment 2 AJ Lewis 2004-09-02 16:44:19 EDT
I no longer see it.  Seems to be fixed.
Comment 3 Kiersten (Kerri) Anderson 2004-11-04 10:07:05 EST
Updates with the proper version and component name.
Comment 4 Kiersten (Kerri) Anderson 2004-11-04 10:14:51 EST
Updates with the proper version and component name.
Comment 5 Kiersten (Kerri) Anderson 2004-11-04 10:20:14 EST
Updates with the proper version and component name. Again, just love out tools.
Comment 6 AJ Lewis 2004-11-04 10:30:10 EST
Appears to be fixed.

Note You need to log in before you can comment on or make changes to this bug.