Bug 1307059 - dnf: state=latest does not install a package
dnf: state=latest does not install a package
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: ansible (Show other bugs)
22
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 10:30 EST by Jan Chaloupka
Modified: 2016-07-19 15:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Chaloupka 2016-02-12 10:30:27 EST
Description of problem:
When installing packages with ansible-playbook, new packages are not installed with state=latest

Version-Release number of selected component (if applicable):
ansible-1.9.4-1.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. create a task and install package not yet installed on a system with state=latest

Actual results:
new package is not installed

Expected results:
new package is installed and the latest

Additional info:
Upstream issues [1], PR with fix [2]
[1] https://github.com/ansible/ansible/issues/12756
[2] https://github.com/ansible/ansible-modules-extras/pull/1660
Comment 1 Jan Chaloupka 2016-02-12 10:31:04 EST
Relevant for 23 and rawhide too.
Comment 2 Toshio Ernie Kuratomi 2016-02-13 07:18:23 EST
Merged upstream.
Comment 3 Toshio Ernie Kuratomi 2016-02-13 08:43:46 EST
Kevin, since we have ansible-2.0 sitting in the updates-testing repo... how would we want to get this fix applied to any fedor apackage?  (i'll put it into the ansible1.9 package when we get it built but that will only be for epel6/7?)
Comment 4 Kevin Fenzi 2016-02-13 12:41:47 EST
So, options are: 

1. Just fix in 2.0.0.x. Jan: would this be ok for you? or do you need a fix in 1.9.x? 

2. Push ansible1.9 to fedora branches too, but I think thats a mess and something to avoid, since it's going to be so short lived and it would be difficult to communicate to fedora users to switch to it if they needed. 

3. Unpush 2.0.0.x from testing, revert git to 1.9.4, apply fix, build and push new 1.9.4 build, get to stable, revert git to 2.0 and push new 2.0.0.x out. This is bad because we have to play with all kinds of git reverting, but also because 2.0.0.x will become unavailable for testers while fixed 1.9.x is in testing. So, not a great solution. 

Not seeing much else... I hope that Jan would be ok switching to a fixed 2.0. ;)
Comment 5 Jan Chaloupka 2016-02-15 02:08:07 EST
Thanks guys.

As long as it gets fixed in F22+, 2) is fine :).

Fedora update for 2.0.* talks about backward incompatibilities with 1.9. Have you managed to fix that?
Comment 6 Kevin Fenzi 2016-02-15 09:10:06 EST
The cases where 2.0.x is incompatible with 1.9.x are either bugs (and upstream is fixing them quickly in 2.0.0.x patches) or cases where the behavior in 1.9 was wrong as well but ansible wasn't able to detect it. 

I encourage you to go test 2.0 for your playbooks and report any incompatibilities...
Comment 7 Fedora End Of Life 2016-07-19 15:24:35 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.