Bug 1307086 - kdelibs FTBFS on rawhide
kdelibs FTBFS on rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-12 11:34 EST by Rex Dieter
Modified: 2016-02-13 18:46 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 21:50:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2016-02-12 11:34:40 EST
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp: In function 'Solid::Processor::InstructionSets Solid::Backends::Shared::cpuFeatures()':
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:60:37: error: inconsistent user-defined literal suffixes 'reg' and 'reg1' in string literal
   #define ASM_MOV_REG(reg1, reg2)   "movl   %%e"reg1", %%e"reg2" \n\t"
                                     ^
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:102:5: note: in expansion of macro 'ASM_MOV_REG'
     ASM_MOV_REG("cx", "dx")             // Copy ECX to EDX
     ^~~~~~~~~~~
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:114:5: error: unable to find string literal operator 'operator""reg' with 'const char [315]', 'unsigned int' arguments
     ".Lno_cpuid_support%=:      \n\t"
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:61:37: error: inconsistent user-defined literal suffixes 'reg' and 'var' in string literal
   #define ASM_MOV_VAR(var, reg)     "movl   "var",     %%e"reg"  \n\t"
                                     ^
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:122:13: note: in expansion of macro 'ASM_MOV_VAR'
             ASM_MOV_VAR("$1", "ax")             // Set EAX to 1 (features request)
             ^~~~~~~~~~~
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:55:52: error: unable to find string literal operator 'operator""reg' with 'const char [100]', 'unsigned int' arguments
   #define ASM_POP(reg)              "popl   %%e"reg"             \n\t"
                                                    ^
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:124:13: note: in expansion of macro 'ASM_POP'
             ASM_POP("bx")                       // Restore EBX
             ^~~~~~~
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:61:37: error: inconsistent user-defined literal suffixes 'reg' and 'var' in string literal
   #define ASM_MOV_VAR(var, reg)     "movl   "var",     %%e"reg"  \n\t"
                                     ^
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:133:14: note: in expansion of macro 'ASM_MOV_VAR'
              ASM_MOV_VAR("$0x80000000", "ax")
              ^~~~~~~~~~~
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:55:52: error: unable to find string literal operator 'operator""reg' with 'const char [283]', 'unsigned int' arguments
   #define ASM_POP(reg)              "popl   %%e"reg"             \n\t"
                                                    ^
/builddir/build/BUILD/kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp:142:14: note: in expansion of macro 'ASM_POP'
              ASM_POP("bx")                      // Restore EBX
              ^~~~~~~
solid/solid/CMakeFiles/solid.dir/build.make:2053: recipe for target 'solid/solid/CMakeFiles/solid.dir/backends/shared/cpufeatures.cpp.o' failed
Comment 1 Rex Dieter 2016-02-12 11:58:21 EST
Looks like a case of "Invalid literal suffixes" as outlined on 
https://gcc.gnu.org/gcc-6/porting_to.html

I'll try the suggested fix of adding whitespace.
Comment 2 Rex Dieter 2016-02-12 13:33:51 EST
Ok, that problem fixed.

Another, CheckPrototypeExists.cmake seems to fail now for some checks, including 
HAVE_TRUNC, see CMakeErrors.log:

Performing C++ SOURCE FILE Test HAVE_TRUNC failed with the following output:
Change Dir: /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/CMakeFiles/CMakeTmp
Run Build Command:"/usr/bin/gmake" "cmTC_68aec/fast"
/usr/bin/gmake -f CMakeFiles/cmTC_68aec.dir/build.make CMakeFiles/cmTC_68aec.dir/build
gmake[1]: Entering directory '/builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/CMakeFiles/CMakeTmp'
Building CXX object CMakeFiles/cmTC_68aec.dir/src.cxx.o
/usr/bin/c++   -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -D_XOPEN_SOURCE=500  -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -DHAVE_TRUNC   -o CMakeFiles/cmTC_68aec.dir/src.cxx.o -c /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/CMakeFiles/CMakeTmp/src.cxx
/builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/CMakeFiles/CMakeTmp/src.cxx: In function 'int main()':
/builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/CMakeFiles/CMakeTmp/src.cxx:7:19: error: address of overloaded function with no contextual type information
    int i = sizeof(&trunc);
Comment 3 Rex Dieter 2016-02-12 14:12:46 EST
Seems newer glibc has 2 prototypes?
one for double (as before) and another new one for float.
Comment 4 Rex Dieter 2016-02-12 16:21:28 EST
and got past that error, and hitting another different one:

[ 44%] Generating ndo.h, ndo.cpp
cd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/kdeui/tests && /usr/bin/cmake -DKDE4_HEADER:BOOL=ON -DKDE_UIC_EXECUTABLE:FILEPATH=/usr/lib/qt4/bin/uic-qt4 -DKDE_UIC_FILE:FILEPATH=/builddir/build/BUILD/kdelibs-4.14.17/kdeui/tests/kcolorutilsdemo.ui -DKDE_UIC_H_FILE:FILEPATH=/builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/kdeui/tests/ui_kcolorutilsdemo.h -DKDE_UIC_BASENAME:STRING=kcolorutilsdemo -P /builddir/build/BUILD/kdelibs-4.14.17/cmake/modules/kde4uic.cmake
cd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/nepomuk && /usr/bin/onto2vocabularyclass --name NDO --encoding trig --namespace Nepomuk::Vocabulary --export-module nepomuk /usr/share/ontology/nepomuk/ndo.trig
cd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/nepomuk/rcgen && /usr/lib/qt4/bin/rcc -name templates -o /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/nepomuk/rcgen/qrc_templates.cxx /builddir/build/BUILD/kdelibs-4.14.17/nepomuk/rcgen/templates.qrc
cd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /builddir/build/BUILD/kdelibs-4.14.17 /builddir/build/BUILD/kdelibs-4.14.17/kjsembed/kjscmd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/kjsembed/kjscmd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/kjsembed/kjscmd/CMakeFiles/kjscmd.dir/DependInfo.cmake --color=
cd /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /builddir/build/BUILD/kdelibs-4.14.17 /builddir/build/BUILD/kdelibs-4.14.17/nepomuk/rcgen /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/nepomuk/rcgen /builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/nepomuk/rcgen/CMakeFiles/nepomuk-rcgen.dir/DependInfo.cmake --color=
Could not find parser plugin for encoding trig
nepomuk/CMakeFiles/nepomuk.dir/build.make:167: recipe for target 'nepomuk/ndo.h' failed
Comment 5 Rex Dieter 2016-02-12 16:50:16 EST
given that the build is failing down in nepomuk/ , maybe it is finally time to consider disabling the deprecated nepomuk support.

$ sudo repoquery --repoid=rawhide --whatrequires 'libnepomuk.so.4()(64bit)'

bangarang-0:2.1-9.fc24.x86_64
contour-0:0.3-6.fc21.x86_64
kimono-0:4.14.3-8.fc24.x86_64
nepomuk-music-kio-slave-0:0.1.0-9.fc24.x86_64
nepomukshell-0:0.8.0-10.fc24.x86_64
plasma-mobile-0:0.4-15.fc24.x86_64
pykde4-0:4.14.3-10.fc24.x86_64
ruby-korundum-0:4.14.3-8.fc24.x86_64
share-like-connect-0:0.3-8.fc24.x86_64
smokekde-0:4.14.3-8.fc23.x86_64
tellico-0:2.3.10-4.fc24.x86_64
Comment 6 Rex Dieter 2016-02-12 19:38:40 EST
OK, fixed that soprano issue, and now...


In file included from /builddir/build/BUILD/kdelibs-4.14.17/khtml/ecma/kjs_traversal.cpp:22:0:
/builddir/build/BUILD/kdelibs-4.14.17/i686-redhat-linux-gnu/khtml/kjs_traversal.lut.h:54:1: error: narrowing conversion of '(DOM::NodeFilter::ShowCode)4294967295u' from 'unsigned int' to 'int' inside { } [-Wnarrowing]
Comment 8 Kevin Kofler 2016-02-13 18:46:10 EST
Thanks Rex! :-)

Note You need to log in before you can comment on or make changes to this bug.