Bug 1307090 - undefined method `vm_destroy' for ManageIQ::Providers::Azure::CloudManager
undefined method `vm_destroy' for ManageIQ::Providers::Azure::CloudManager
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Bronagh Sorota
Jeff Teehan
azure:retirement
: ZStream
Depends On:
Blocks: 1309800
  Show dependency treegraph
 
Reported: 2016-02-12 11:59 EST by ncatling
Modified: 2016-07-27 01:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1309800 (view as bug list)
Environment:
Last Closed: 2016-03-09 11:24:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ncatling 2016-02-12 11:59:38 EST
Description of problem:
Azure instance terminate button does not work.

Version-Release number of selected component (if applicable):


How reproducible:
Select Azure instance, then Power > Terminate.


Steps to Reproduce:
1. Select instance
2. Select power
3. Select terminate

Actual results:
Instance not terminated. Following error produced in evm.log
undefined method `vm_destroy' for #<ManageIQ::Providers::Azure::CloudManager

Expected results:
Instance is terminated.


Additional info:
[----] E, [2016-02-12T10:59:26.159217 #26340:f4b988] ERROR -- : MIQ(MiqQueue#m_callback) Message id: [1000008730298]: undefined method `vm_destroy' for #<ManageIQ::Providers::Azure::CloudManager:0x0000000240b620>
[----] D, [2016-02-12T10:59:26.159305 #26340:f4b988] DEBUG -- : MIQ(MiqQueue#m_callback) backtrace: /opt/rh/cfme-gemset/gems/activemodel-4.2.5.1/lib/active_model/attribute_methods.rb:433:in `method_missing'
/var/www/miq/vmdb/app/models/vm_or_template.rb:328:in `run_command_via_parent'
/var/www/miq/vmdb/app/models/vm_or_template/operations.rb:54:in `raw_destroy'
/var/www/miq/vmdb/app/models/vm_or_template.rb:352:in `check_policy_prevent_callback'
/var/www/miq/vmdb/app/models/miq_queue.rb:414:in `m_callback'
/var/www/miq/vmdb/app/models/miq_queue.rb:383:in `delivered'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:117:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:334:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:128:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:29:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
Comment 2 Greg Blomquist 2016-02-18 09:41:41 EST
vm_destroy is part of VM Retirement, which is on the Azure roadmap.
Comment 5 Jeff Teehan 2016-03-08 17:45:12 EST
It seems to working just fine in the latest 5.6 build.  Did you change something?
cfme-hyperv-5.6.0.0-nightly-20160308112121-1.x86_64.vhd
Comment 6 Bronagh Sorota 2016-03-09 11:14:56 EST
Actually we didn't change anything, the vm_destroy method has been in place for some time.
Comment 7 Jeff Teehan 2016-03-09 11:20:24 EST
So, was it just that old API version we were using didn't support it and with the new API version it does?  So we want to close this as no longer applicable?  It doesn't seem to be a 5.6 issue which is where it is currently assigned.
Comment 8 Bronagh Sorota 2016-03-09 11:24:03 EST
We never supported the ASM API. I will close this ticket.
Comment 9 Jeff Teehan 2016-03-09 11:26:53 EST
Never mind.  Closed works for me.
Comment 10 Jeff Teehan 2016-07-27 01:41:35 EDT
Moving QE contact back to me in case it comes back in the future.

Note You need to log in before you can comment on or make changes to this bug.