Bug 1307112 - ERROR: IPC protocol violation! The CLI and the usbguard-daemon aren't compatible.
ERROR: IPC protocol violation! The CLI and the usbguard-daemon aren't compati...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: usbguard (Show other bugs)
23
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 12:51 EST by Christian Stadelmann
Modified: 2016-07-21 19:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: usbguard-0.5.10-1.fc24 usbguard-0.5.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-16 20:52:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result from running `strace usbguard list-devices` (21.75 KB, text/plain)
2016-02-12 12:51 EST, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2016-02-12 12:51:23 EST
Created attachment 1123603 [details]
Result from running `strace usbguard list-devices`

Description of problem:
On a fresh (unconfigured) installation of usbguard, I cannot interact with the daemon.

Version-Release number of selected component (if applicable):
usbguard-0.4-4.fc23.x86_64

How reproducible:
don't know yet

Steps to Reproduce:
1. install usbguard
2. start daemon with systemd as root/sudo: `systemctl start usbguard.service`
3. run `usbguard list-devices` to interact with the daemon

Actual results:
I get an error:
Lexer.cpp:5151:	ERROR: IPC protocol violation! The CLI and the usbguard-daemon aren't compatible.

Expected results:
some interaction

Additional info:
This issue might be caused by me setting umask to 0077 for all users.

$ systemctl -l status usbguard.service
● usbguard.service - USBGuard daemon
   Loaded: loaded (/usr/lib/systemd/system/usbguard.service; disabled; vendor preset: disabled)
   Active: active (running) since Fr 2016-02-12 18:34:57 CET; 10min ago
 Main PID: 22912 (usbguard-daemon)
   CGroup: /system.slice/usbguard.service
           └─22912 /usr/sbin/usbguard-daemon -k -c /etc/usbguard/usbguard-daemon.conf

Feb 12 18:34:57 hostname systemd[1]: Started USBGuard daemon.
Feb 12 18:34:57 hostname systemd[1]: Starting USBGuard daemon...
Feb 12 18:34:57 hostname usbguard-daemon[22912]: [2016-02-12 18:34:57.083184] warning: The configured rule file doesn't yet exists. Starting with an empty rule set.
Comment 1 Christian Stadelmann 2016-02-12 12:53:57 EST
I should probably add that the user account I was running `usbguard` from is member of group "wheel", which is permitted to IPC with usbguard by default. Running `usbguard` as root doesn't work around this error either.
Comment 2 Christian Stadelmann 2016-02-12 13:06:40 EST
This issue is not present in usbguard 0.5-1 from https://copr.fedorainfracloud.org/coprs/mildew/usbguard/
Comment 3 Daniel Kopeček 2016-02-12 13:11:12 EST
Hello, thanks for the report! What locale to you use on your system? Could you please test whether running

$ LC_NUMERIC=C usbguard list-devices

works?
Comment 4 Christian Stadelmann 2016-02-12 14:03:33 EST
No, it doesn't, still the same error message.
Comment 5 Christian Stadelmann 2016-02-12 14:30:59 EST
Sorry, I forgot to answer the first part of your question. My locale is LANG=de_DE.UTF-8
Comment 6 Christian Stadelmann 2016-07-08 11:41:53 EDT
usbguard- and -applet-qt- 0.5-9.fc24.x86_64 work fine, no crash any more. Thank you!
Comment 7 Daniel Kopeček 2016-07-08 11:46:11 EDT
(In reply to Christian Stadelmann from comment #6)
> usbguard- and -applet-qt- 0.5-9.fc24.x86_64 work fine, no crash any more.
> Thank you!

Thanks for letting me know. I'll push an update to Fedora repositories once I figure out some minor build system issues in the upstream code.
Comment 8 Fedora Update System 2016-07-09 16:54:40 EDT
usbguard-0.5.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-86faff2b57
Comment 9 Fedora Update System 2016-07-09 16:54:48 EDT
usbguard-0.5.10-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ab3c68099a
Comment 10 Fedora Update System 2016-07-09 16:54:53 EDT
usbguard-0.5.10-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca3dc9fed5
Comment 11 Fedora Update System 2016-07-11 23:27:25 EDT
usbguard-0.5.10-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca3dc9fed5
Comment 12 Fedora Update System 2016-07-11 23:56:08 EDT
usbguard-0.5.10-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-86faff2b57
Comment 13 Fedora Update System 2016-07-11 23:59:36 EDT
usbguard-0.5.10-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ab3c68099a
Comment 14 Fedora Update System 2016-07-16 20:52:27 EDT
usbguard-0.5.10-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2016-07-21 19:21:22 EDT
usbguard-0.5.10-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.