Bug 1307117 - getting started guide should warn about yum repos that may be enabled outside of subscription-manager scope
getting started guide should warn about yum repos that may be enabled outside...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Zac Dover
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 13:20 EST by Dave Sullivan
Modified: 2016-05-16 00:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-16 00:00:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2016-02-12 13:20:40 EST
Document URL: 

https://access.redhat.com/documentation/en/red-hat-atomic-enterprise-platform/version-3.1/getting-started-guide/

Section Number and Name: 

Chapter 2 step 3 

subscription-manager repos --disable="*"

Describe the issue: 

In most situations this is good, however it's possible that customers have additional yum repos enabled.  And outside of /etc/yum.repos.d/redhat.repo the command above doesn't cover.  Because any additional repos outside of redhat.repo/subscription-manager scope could cause unknown conflicts we should make a note to watch.

Suggestions for improvement: 

Add an additional check after step 3

[root@aepmaster001 yum.repos.d]# yum repolist
Loaded plugins: langpacks, product-id, subscription-manager
repolist: 0

If it is not 0 then you have other yum repos outside of subscription-manager's scope and these could cause unknown conflicts, recommend that they be disabled before proceeding or recommend that the admin validate that they do not conflict with the redhat.repo provided repositories.


Additional information:
Comment 1 Dave Sullivan 2016-02-12 13:44:17 EST
Also after step 3 after yum repolist it would probably be good to train customers to do a check with repoclosure that's actually how they would know whether any additional yum repos that they may want impact this environment

As you can see we have dep issues with only our supplied repos, which sort of also tells me we must be missing this step in QA

http://pastebin.test.redhat.com/348529
Comment 4 Vikram Goyal 2016-05-16 00:00:30 EDT
The note to remind readers about external repos can be verified here [1].

Moving this to CLOSED-->CURRENTRELEASE.

[1] https://access.redhat.com/documentation/en/red-hat-atomic-enterprise-platform/version-3.2/getting-started-guide/#aep_getting_started_procedure

Note You need to log in before you can comment on or make changes to this bug.