Bug 130713 - pvcreate needs to wipe raid component signature
Summary: pvcreate needs to wipe raid component signature
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
: 134879 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-23 21:05 UTC by Jeremy Katz
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 16:01:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2004-08-23 21:05:32 UTC
If I do pvcreate on a device that used to be part of a RAID array, the
md signature doesn't get wiped from the disk.  

This is a bit less than ideal.

Comment 1 Jesse Barnes 2004-10-14 17:41:19 UTC
*** Bug 134879 has been marked as a duplicate of this bug. ***

Comment 2 Alasdair Kergon 2004-11-19 19:35:16 UTC
pvcreate updated in CVS to do this.

But if --uuid or --restorefile is specified without -y, it asks the
question: these options are normally used when recovering metadata
from a backup and in cases like that you might well want the md
superblock left intact.

After running an md command, always run vgscan before running any
other LVM command.


Comment 3 Alasdair Kergon 2004-11-23 18:44:20 UTC
Included in 2.00.26 source.


Note You need to log in before you can comment on or make changes to this bug.