Bug 1307137 - nodejs-bluebird RPM content does not match NPM module
nodejs-bluebird RPM content does not match NPM module
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: nodejs-bluebird (Show other bugs)
epel7
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Piotr Popieluch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 14:13 EST by Jordan Reuter
Modified: 2016-03-02 15:01 EST (History)
3 users (show)

See Also:
Fixed In Version: nodejs-bluebird-2.3.11-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 15:01:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Reuter 2016-02-12 14:13:55 EST
Description of problem:
Attempting to install this package via yum installs the wrong files. I expect the contents of the RPM to be similar, if not identical to the contents of the corresponding NPM package.

Version-Release number of selected component (if applicable):
2.2.2-1.el7

How reproducible:
always

Steps to Reproduce:
1. Install this package with `yum install nodejs-bluebird`
2. At a node shell, type `require('bluebird');`

Actual results:
NodeJS exits after this fatal error:

Error: Cannot find module 'bluebird'

Expected results:
NodeJS successfully `require()`s the module.

Additional info:

It seems as though the wrong files have been bundled into the RPM.
Directory structure after package installation (note presence of zalgo.js):

/lib/node_modules/bluebird/
├── node_modules
├── package.json
└── zalgo.js

After removing the yum package and reinstalling globally with `npm -g i bluebird@2.2.2`, this is the directory structure:
/lib/node_modules/bluebird/
├── js
│   ├── main
│   │   ├── any.js
│   │   ├── assert.js
│   │   ├── async.js
│   │   ├── bluebird.js
│   │   ├── call_get.js
│   │   ├── cancel.js
│   │   ├── captured_trace.js
│   │   ├── catch_filter.js
│   │   ├── direct_resolve.js
│   │   ├── each.js
│   │   ├── errors_api_rejection.js
│   │   ├── errors.js
│   │   ├── es5.js
│   │   ├── filter.js
│   │   ├── finally.js
│   │   ├── generators.js
│   │   ├── join.js
│   │   ├── map.js
│   │   ├── nodeify.js
│   │   ├── progress.js
│   │   ├── promise_array.js
│   │   ├── promise.js
│   │   ├── promise_resolver.js
│   │   ├── promisify.js
│   │   ├── props.js
│   │   ├── queue.js
│   │   ├── race.js
│   │   ├── reduce.js
│   │   ├── schedule.js
│   │   ├── settle.js
│   │   ├── some.js
│   │   ├── synchronous_inspection.js
│   │   ├── thenables.js
│   │   ├── timers.js
│   │   ├── using.js
│   │   └── util.js
│   └── zalgo
│       ├── any.js
│       ├── assert.js
│       ├── async.js
│       ├── bluebird.js
│       ├── call_get.js
│       ├── cancel.js
│       ├── captured_trace.js
│       ├── catch_filter.js
│       ├── direct_resolve.js
│       ├── each.js
│       ├── errors_api_rejection.js
│       ├── errors.js
│       ├── es5.js
│       ├── filter.js
│       ├── finally.js
│       ├── generators.js
│       ├── join.js
│       ├── map.js
│       ├── nodeify.js
│       ├── progress.js
│       ├── promise_array.js
│       ├── promise.js
│       ├── promise_resolver.js
│       ├── promisify.js
│       ├── props.js
│       ├── queue.js
│       ├── race.js
│       ├── reduce.js
│       ├── schedule.js
│       ├── settle.js
│       ├── some.js
│       ├── synchronous_inspection.js
│       ├── thenables.js
│       ├── timers.js
│       ├── using.js
│       └── util.js
├── LICENSE
├── package.json
├── README.md
└── zalgo.js
Comment 1 Piotr Popieluch 2016-02-13 07:06:22 EST
Looks like this is fixed in 2.3 version which is commited to the epel7 branch but was not yet built.

I just built it, seems all deps are fine. 

Ralph, OK if I push the update 2.3 to epel7?
Comment 2 Fedora Update System 2016-02-15 09:32:26 EST
nodejs-bluebird-2.3.11-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-9b67518519
Comment 3 Fedora Update System 2016-02-16 23:49:53 EST
nodejs-bluebird-2.3.11-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-9b67518519
Comment 4 Fedora Update System 2016-03-02 15:01:17 EST
nodejs-bluebird-2.3.11-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.