Bug 130714 - SELinux FAQ - installing SELinux steps incorrect
SELinux FAQ - installing SELinux steps incorrect
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: selinux-faq (Show other bugs)
devel
All Linux
high Severity medium
: ---
: ---
Assigned To: Karsten Wade
Tammy Fox
http://people.redhat.com/kwade/fedora...
:
Depends On:
Blocks: 118757
  Show dependency treegraph
 
Reported: 2004-08-23 17:09 EDT by Karsten Wade
Modified: 2007-03-27 00:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 17:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2004-08-23 17:09:51 EDT
[Description of change/FAQ addition.  If a change, include the
original text first, then the changed text:]

The first two steps should read as follows, to reflect a package
mistake and a fore-shortened step.

1. Install a policy and the policy utilities with yum install policy
policycoreutils.

2. Create or edit /etc/sysconfig/selinux and set SELINUX=permissive in
it.  The file should have the standard permissions set with chmod 644
/etc/sysconfig/selinux.

It might help to do another relabeling, so fix the last step to read:

4.  Reboot your system. Check /var/log/messages for avc: denied
messages.  You may need to relabel the files again now that you are
running fully under an &SEL; policy domain. Resolve any issues while
still in permissive mode, and once you can boot without avc denials,
set SELINUX=enforcing in /etc/sysconfig/selinux.

Need to get this from CVS to f.r.c/docs.


Version-Release of FAQ

 selinux-faq-1.2-6 (2004-08-11-T16:20-0800)
Comment 1 Karsten Wade 2004-08-23 17:43:58 EDT
Fixed in CVS, on p.r.c/kwade/fedora-docs/selinux-faq-en:
Comment 2 Karsten Wade 2004-08-26 20:48:43 EDT
Reopening because of an error in the HTML build:

            </a></dt><dt>Q:. <a href="index.html"#id3342630>
              What is SELinux policy?
            </a></dt><dt>Q:. <a href="index.html"#id3342714>

              What are file contexts?
            </a></dt><dt>Q:. <a href="index.html"#id3342813>

Throughout the ToC the href tags have the #idxxxxxxx outside of the ""
target.  

This doesn't happen in the standard build, so I'm assuming it's in the
package built to go to f.r.c/docs.
Comment 3 Tammy Fox 2004-08-26 21:20:36 EDT
I found out where the problem is. The HTML generated is fine, and the
PHP generated from the DocBook HTML is fine. It is the script that
converts from PHP to HTML for the website that messes up the links; it
looks for all hrefs that end in .php and converts them to .html. I'll
ask the script writer to look at it.
Comment 4 Karsten Wade 2004-10-22 17:39:19 EDT
Although the behavior still exists on the fedora.r.c/ site, going to
reclose this bug as no longer relevant, i.e., the secondary problem
wasn't related to this bug.

Note You need to log in before you can comment on or make changes to this bug.