This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1307190 - RFE: add new python RPM macros to python-devel
RFE: add new python RPM macros to python-devel
Status: CLOSED DUPLICATE of bug 1297522
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Orsava
BaseOS QE - Apps
: FutureFeature
: 1305852 (view as bug list)
Depends On: 1297522
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 19:06 EST by Ken Dreyer (Red Hat)
Modified: 2017-03-22 09:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-22 09:02:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Dreyer (Red Hat) 2016-02-12 19:06:43 EST
Description of problem:
Fedora's new python macros are not available in RHEL 7.

Version-Release number of selected component (if applicable):
python-devel-2.7.5-34.el7

How reproducible:
always

Steps to Reproduce:
1. Set up a RHEL system
2. yum install python-devel
3. rpm --eval %{py2_build} 

Actual results:
RPM returns the literal string "%{py2_build}", the macro does not expand.

Expected results:
This macro and the rest of the newer Python macros are available for use in RPMs.

Additional info:
This makes it hard to share an RPM between Fedora and Red Hat's layered products. It even makes it hard to copy an RPM from EPEL, because a simple EPEL python-foo SRPM that uses these macros will not rebuild in a plain RHEL mock chroot.

The EPEL project has already added these macros to their "rpm-macros" package. See the /usr/lib/rpm/macros.d/macros.epel-rpm-macros in the epel-rpm-macros-7-5.noarch package. https://bugzilla.redhat.com/show_bug.cgi?id=1241655
Comment 2 Ken Dreyer (Red Hat) 2016-02-15 16:14:38 EST
(In reply to Ken Dreyer (Red Hat) from comment #0)
> The EPEL project has already added these macros to their "rpm-macros"
> package. See the /usr/lib/rpm/macros.d/macros.epel-rpm-macros in the
> epel-rpm-macros-7-5.noarch package.
> https://bugzilla.redhat.com/show_bug.cgi?id=1241655

I'm wrong - the actual package is not epel-rpm-macros, but a dependency, python-rpm-macros. See http://pkgs.fedoraproject.org/cgit/rpms/python-rpm-macros.git/tree/macros.python?h=epel7 for example.
Comment 3 Robert Kuska 2016-03-09 05:55:04 EST
*** Bug 1305852 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2017-02-15 15:04:37 EST
Are there corresponding tickets for RHEL 5 and 6?
Comment 5 Tomas Orsava 2017-02-16 03:35:02 EST
(In reply to Adam Williamson from comment #4)
> Are there corresponding tickets for RHEL 5 and 6?

No, this is RHEL 7–only.
Comment 6 Tomas Orsava 2017-03-22 09:02:39 EDT
I'm closing this RFE as a duplicate of BZ#1297522, because the solution thereof involves adding new Python RPM macros to python-devel, thus solving this request as well.

*** This bug has been marked as a duplicate of bug 1297522 ***

Note You need to log in before you can comment on or make changes to this bug.