Bug 1307202 - package config file (/usr/i686-w64-mingw32/sys-root/mingw/lib/pkgconfig/libzip.pc) missing paths
Summary: package config file (/usr/i686-w64-mingw32/sys-root/mingw/lib/pkgconfig/libzi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw-libzip
Version: 23
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-13 00:51 UTC by Gene Hightower
Modified: 2016-02-23 01:24 UTC (History)
2 users (show)

Fixed In Version: mingw-libzip-1.1.1-1.fc22 mingw-libzip-1.1.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-22 20:49:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Gene Hightower 2016-02-13 00:51:31 UTC
Description of problem:

The package config file install is missing important path information.

----------------------------------------------------------------------------------------
$ more /usr/i686-w64-mingw32/sys-root/mingw/lib/pkgconfig/libzip.pc
prefix=
exec_prefix=
libdir=
includedir=
libincludedir=/libzip/include

zipcmp=/bin/zipcmp

Name: libzip
Description: library for handling zip archives
Version: 1.1
Libs:  -L${libdir} -lzip -lz
Cflags: -I${includedir} -I${libincludedir}
----------------------------------------------------------------------------------------

Clearly prefix etc. are not set correctly.  Should read more like:

prefix=/usr/i686-w64-mingw32/sys-root/mingw
exec_prefix=/usr/i686-w64-mingw32/sys-root/mingw
libdir=/usr/i686-w64-mingw32/sys-root/mingw/lib
includedir=/usr/i686-w64-mingw32/sys-root/mingw/include
libincludedir=/usr/i686-w64-mingw32/sys-root/mingw/lib/libzip/include

The issues seems to be use of cmake for this build without running the
configure script as is done for "native" builds.  The configure script
properly makes the .pc file from the .pc.in file with the proper
substitutions.

Version-Release number of selected component (if applicable):

Seems broken in rawhide, too.  Used to be right in Fedora 22.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

Result is, build systems that use pkg-config end up horked.

Expected results:


Additional info:

Comment 1 Fedora Update System 2016-02-13 12:18:11 UTC
mingw-libzip-1.1.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-85c9988d16

Comment 2 Fedora Update System 2016-02-13 12:18:11 UTC
mingw-libzip-1.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f61a528ae

Comment 3 Fedora Update System 2016-02-15 04:52:36 UTC
mingw-libzip-1.1.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-85c9988d16

Comment 4 Fedora Update System 2016-02-15 05:24:14 UTC
mingw-libzip-1.1.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f61a528ae

Comment 5 Gene Hightower 2016-02-16 19:29:29 UTC
I tested the package and it look great to me.

Thanks!

Comment 6 Sandro Mani 2016-02-16 21:32:17 UTC
Thanks for the feedback and for reporting the bug!

Comment 7 Fedora Update System 2016-02-22 20:49:37 UTC
mingw-libzip-1.1.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-02-23 01:24:10 UTC
mingw-libzip-1.1.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.