Bug 1307204 - xorg-x11-drv-ati-7.6.0-0.4.20150729git5510cd6 incompatible with xorg-x11-server-1.18
xorg-x11-drv-ati-7.6.0-0.4.20150729git5510cd6 incompatible with xorg-x11-serv...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 22:00 EST by Eric Hattemer
Modified: 2016-02-21 11:26 EST (History)
3 users (show)

See Also:
Fixed In Version: 7.6.1 2015-12-11 git xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-21 08:01:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Hattemer 2016-02-12 22:00:58 EST
Description of problem:

When adding a 3rd or 4th monitor from a second card with xrandr --output ..--right-of..., Xorg.0.log throws:
"Cannot do multiple crtcs without X server dirty tracking 2 interface\n"
and errors about slave pixmap memory.

Version-Release number of selected component (if applicable):

7.6.0-0.4.20150729git5510cd6

How reproducible:

Need 4ish monitors.

Steps to Reproduce:
1. Get 2 Radeon cards with 2 ports each (I have two 5450's with 512MB each).
2. Use a blank device/screen/screenlayout/monitor setup
3. After two monitors activate, try using xrandr to activate a third and fourth

Actual results:

The third monitor activates in a sketchy mode where it doesn't work.  The fourth monitor refuses to activate.


Expected results:

Both extra monitors activate.


Additional info:

The problem is that xorg 1.17 or 1.18 replaced "HAS_DIRTYTRACKING2" with "HAS_DIRTYTRACKING_ROTATION" in pixmap.h and the old version of xf86-video-ati still looks for HAS_DIRTYTRACKING2.  The newest version of xf86-video-ati looks for either:
#if !defined(HAS_DIRTYTRACKING_ROTATION) && !defined(HAS_DIRTYTRACKING2)

I took the spec file from xorg-x11-drv-ati-7.6.0-0.4.20150729git5510cd6.fc23.src.rpm and the source from git://anongit.freedesktop.org/xorg/driver/xf86-video-ati , connected the two, got rid of the comments with %'s in them (not sure why that's a problem), and it seems to work fine now.  I'm not sure where the git5510cd6 string comes from.  The version I'm using ends in:
commit d41fcccf2f11d0393d252e76bbbe6d233c4ac443
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Wed Jan 20 11:20:30 2016 +0900


With 4 monitors and Xinerama off, I get like 5fps, but at least it's consistent (with 2 monitors and vsync off, I can get hundreds).  With Xinerama on and the old 7.6.0-0.4.20150729git5510cd6 driver, compiz-manager would stall out for up to a minute every other time a window was closed.  So I'd call this an improvement, sort of, but you should still do your own testing for the 1/20 version before releasing it.
Comment 1 Fedora Update System 2016-02-14 22:03:12 EST
xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc23 xorg-x11-drv-nouveau-1.0.12-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-caddc95794
Comment 2 Fedora Update System 2016-02-17 01:29:51 EST
xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc23, xorg-x11-drv-nouveau-1.0.12-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-caddc95794
Comment 3 Fedora Update System 2016-02-21 08:00:56 EST
xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc23, xorg-x11-drv-nouveau-1.0.12-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2016-02-21 11:20:13 EST
xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc23, xorg-x11-drv-nouveau-1.0.12-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2016-02-21 11:26:05 EST
xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc23, xorg-x11-drv-nouveau-1.0.12-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.