Bug 1307211 - [DOCS] [3.2] Document that fsck is run before mount
[DOCS] [3.2] Document that fsck is run before mount
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Thien-Thi Nguyen
Jianwei Hou
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-13 00:17 EST by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-16 12:24:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2016-02-13 00:17:32 EST
In OSE 3.2, the system will run a fsck (file system consistency check) before a mount operation on a new volume is run.

This might just be a note in the guide, but make sure to explain the rationale for this feature.

Dev for this feature is:
Sami Wagiaalla

QA for this feature is:
Jianwei Hou

Trello card is:
https://trello.com/c/XU3VznyD/45-3-fsck-before-mount-just-to-make-sure-it-s-clean-each-time-openshift-online-ops-rfe-origin

Likely Guide is:
https://docs.openshift.com/enterprise/3.1/dev_guide/volumes.html
Comment 1 Thien-Thi Nguyen 2016-03-11 11:23:20 EST
Hi Sami,

IIUC fsck(8) is done prior to mount(8), and mount is done for both "oc volume --add" and "oc volume --add --overwrite" (documented in sections "Adding Volumes" and "Updating Volumes", respectively -- see link in BZ Description).

Here are some questions, the set in a small decision-tree format, and the latter regarding the reason for calling fsck:

- Is this correct?
- If yes:
    - Are the fsck calls identical in these two scenarios?
    - If yes: I plan to add a blurb in the Overview.  WDYT?
    - If no: What are the differences in fsck calls in these two scenarios?
- If no:
    - Could you please explain in which scenarios fsck is called?

Regarding the blurb, i will add something along the lines of:
"Prior to the actual mount(8) call, OpenShift calls fsck(8) to <REASON>."

My question here is: What to put for <REASON>?
Comment 3 Sami Wagiaalla 2016-03-11 15:51:06 EST
> IIUC fsck(8) is done prior to mount(8), and mount is done for both "oc
> volume --add" and "oc volume --add --overwrite" (documented in sections
> "Adding Volumes" and "Updating Volumes", respectively -- see link in BZ
> Description).
> 
> Here are some questions, the set in a small decision-tree format, and the
> latter regarding the reason for calling fsck:
> 
> - Is this correct?

Yes that is correct.

> - If yes:
>     - Are the fsck calls identical in these two scenarios?

They are yes.

>     - If yes: I plan to add a blurb in the Overview.  WDYT?

The blurb sounds good to me!

> Regarding the blurb, i will add something along the lines of:
> "Prior to the actual mount(8) call, OpenShift calls fsck(8) to <REASON>."
> 
> My question here is: What to put for <REASON>?

You can add something like: to ensure that the file system on the volume contains no errors and, if errors are present, to repair them when possible.
Comment 4 Thien-Thi Nguyen 2016-03-13 14:38:53 EDT
PR: https://github.com/openshift/openshift-docs/pull/1733
Moving status to MODIFIED.
Comment 6 Thien-Thi Nguyen 2016-03-15 09:03:29 EDT
Thanks Sami and Alex for the technical and peer reviews, respectively.

JianWei, WDYT?
Comment 8 openshift-github-bot 2016-03-16 13:12:03 EDT
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/995379bad019a9bbcd71a0874964f0555c9c0620
Merge pull request #1733 from tnguyen-rh/bz1307211

Bug 1307211 - Mention fsck(8) prior to mount(8) in "Volumes" Overview.
Comment 11 Jianwei Hou 2016-03-27 22:14:47 EDT
This documentation looks good to me! Mark this bug as verified, thanks!

Note You need to log in before you can comment on or make changes to this bug.