Bug 1307253 - [abrt] hamster-time-tracker: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.637 was not provided by any .service files
[abrt] hamster-time-tracker: connection.py:651:call_blocking:DBusException: o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
23
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:9a51ebb91a5405fff1b85b98fe1...
:
: 1307110 1307259 1308376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-13 11:55 EST by Niki Guldbrand
Modified: 2016-02-25 03:52 EST (History)
12 users (show)

See Also:
Fixed In Version: hamster-time-tracker-2.0-0.3.rc1.fc23 hamster-time-tracker-2.0-0.3.rc1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 15:52:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.34 KB, text/plain)
2016-02-13 11:55 EST, Niki Guldbrand
no flags Details
File: environ (1.97 KB, text/plain)
2016-02-13 11:56 EST, Niki Guldbrand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 755721 None None None 2016-02-13 16:16 EST

  None (edit)
Description Niki Guldbrand 2016-02-13 11:55:53 EST
Description of problem:
Tried to launch it after the update to 2.0 rc1

Version-Release number of selected component:
hamster-time-tracker-2.0-0.2.rc1.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        python2 /usr/bin/hamster overview
dso_list:       dbus-python-1.2.0-12.fc23.x86_64
executable:     /usr/bin/hamster
kernel:         4.3.5-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.637 was not provided by any .service files

Traceback (most recent call last):
  File "/usr/bin/hamster", line 391, in <module>
    getattr(hamster_client, command)(*args)
  File "/usr/bin/hamster", line 152, in overview
    self._launch_window("overview")
  File "/usr/bin/hamster", line 143, in _launch_window
    getattr(server, window_name)()
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.637 was not provided by any .service files

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SessionBus (session) at 0x7fa4f3d7fd10>
args: ()
object_path: '/org/gnome/Hamster/WindowServer'
signature: None
bus_name: dbus.UTF8String(':1.634')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
timeout: -1.0
kwargs: {}
dbus_interface: None
message: <dbus.lowlevel.MethodCallMessage path: /org/gnome/Hamster/WindowServer, iface: n/a, member: overview dest: :1.634>
method: 'overview'
Comment 1 Niki Guldbrand 2016-02-13 11:55:59 EST
Created attachment 1123830 [details]
File: backtrace
Comment 2 Niki Guldbrand 2016-02-13 11:56:01 EST
Created attachment 1123831 [details]
File: environ
Comment 3 Felix Schwarz 2016-02-13 12:05:24 EST
This seems to be a problem in the upstream code, there were multiple reports upstream already: https://github.com/projecthamster/hamster/issues/263
(The same happens on my machine.)

Btw: I'm not thrilled that this -rc code made it into Fedora stable even more so that the new version crashes immediately after startup (at least in some - likely common - situations). At least I can confirm the issue, same happens for me.
Comment 4 Felix Schwarz 2016-02-13 12:07:17 EST
Btw: The current workaround is to use 1.04-5.fc23 ("sudo dnf downgrade hamster-time-tracker")
Comment 5 Raphael Groner 2016-02-13 13:32:16 EST
*** Bug 1307259 has been marked as a duplicate of this bug. ***
Comment 6 Raphael Groner 2016-02-13 14:01:55 EST
*** Bug 1307110 has been marked as a duplicate of this bug. ***
Comment 7 Raphael Groner 2016-02-13 14:02:47 EST
(In reply to Raphael Groner from comment #6)
> *** Bug 1307110 has been marked as a duplicate of this bug. ***

Downgrade would not help. In bug #1307110 an user reports this crash for both versions 1.04 and 2.0 rc1.
Comment 8 Raphael Groner 2016-02-13 16:16:38 EST
Commit d869f7da0eec48df1f52771fed8ed12b12fbab61 at upstream tries to work around this crash.

As discussed in IRC, the bug is found in glib2.
Comment 9 Felix Schwarz 2016-02-14 17:39:31 EST
*** Bug 1308376 has been marked as a duplicate of this bug. ***
Comment 10 Markus Heberling 2016-02-15 04:32:10 EST
(In reply to Raphael Groner from comment #7)
> (In reply to Raphael Groner from comment #6)
> > *** Bug 1307110 has been marked as a duplicate of this bug. ***
> 
> Downgrade would not help. In bug #1307110 an user reports this crash for
> both versions 1.04 and 2.0 rc1.

Downgrading did work for me, so might be worth trying out for others, if they run into the same problem.
Comment 11 Felix Schwarz 2016-02-15 05:03:18 EST
(In reply to Markus Heberling from comment #10)
> Downgrading did work for me, so might be worth trying out for others, if
> they run into the same problem.

What I learnt from my debugging is that error messages like the one here are just "high-level symptoms". Basically Hamster starts two background processes and communicates with them using dbus. Now if you see an error message like "ServiceUnknown" this usually means one of these background processes crashed so the dbus query timed out.

For Hamster 2.0 downgrading is likely to help in all cases until Fedora's package is fixed. For reports with Hamster 1.x downgrading (obviously) won't be an option but users could debug this by starting "hamster-service" and "hamster-windows-service" manually using the command line (they should see backtraces etc there). However Hamster 1.x is not supported anymore by upstream so debugging these old problems is not really worthwile.
Comment 12 Raphael Groner 2016-02-15 05:12:19 EST
Felix, thanks a lot for debugging this. The root cause wasn't easy to find. As hamster is now a central package for several other user interfaces (i.e. GNOME, Xfce) and Ankur and me are of limited free time to care, we need more co-maintainers. Do you want to become a co-maintainer? If yes, please request so in PkgDB and I can approve. :)
Comment 13 Raphael Groner 2016-02-15 05:14:20 EST
(In reply to Markus Heberling from comment #10)
> Downgrading did work for me, so might be worth trying out for others, if
> they run into the same problem.

Sure. But version 1.04 had also a bunch of abrt bugs. Currently, I can not say for sure if they had the same root cause as now Felix found out.
Comment 14 Felix Schwarz 2016-02-15 05:18:01 EST
(In reply to Raphael Groner from comment #12)
> Felix, thanks a lot for debugging this. The root cause wasn't easy to find.
> As hamster is now a central package for several other user interfaces (i.e.
> GNOME, Xfce) and Ankur and me are of limited free time to care, we need more
> co-maintainers. Do you want to become a co-maintainer? If yes, please
> request so in PkgDB and I can approve. :)

Thank you very much for the offer. Right now I'm just watching hamster as I already neglect my Fedora packages too much and on top I'm not really sure if I like the UI of hamster 2 so maybe I'll fork that anyway + develop something on top to resolve the feature regressions.

(In reply to Raphael Groner from comment #13)
> But version 1.04 had also a bunch of abrt bugs. Currently, I can not
> say for sure if they had the same root cause as now Felix found out.

1.04 had it's fair share of problems, yes. However the gio bug wasn't triggered in 1.04 because the old version did not set the problematic monitoring flag.
Comment 15 Fedora Update System 2016-02-15 14:10:06 EST
hamster-time-tracker-2.0-0.3.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c97f297cd6
Comment 16 Fedora Update System 2016-02-15 14:10:07 EST
hamster-time-tracker-2.0-0.3.rc1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d556fdafa
Comment 17 Hedayat Vatankhah 2016-02-15 15:31:19 EST
The update does fix the startup problem. But there are a number of problems in this new version:
1. It fails to export anything for me. The save dialog doesn't appear initially. The second try, it appears but save button doesn't work.

2. There is still two icons for Hamster: Timer tracker & Time tracker overview. Both of them open the main hamster window. (There is no overview UI anymore).

3. The UI is considerably different from 1.x series. I wonder if it is really appropriate for F23 & specially F23. I personally miss the tray icon. Should I keep the window open (and clutter my Alt+Tab list & make switching between windows harder)?! OK, actually I don't complain why it is in F23. It'll just make me feel the pain a bit later (F24). Anyway, this item is probably too off topic. Sorry.
Comment 18 Hedayat Vatankhah 2016-02-15 15:52:40 EST
sorry to bother you again, I found new info:
1. The new window is actually the overview window!
2. The main window is effectively replaced by https://extensions.gnome.org/extension/425/project-hamster-extension/

This means that, IMHO, without this extension, the package is not complete. I wonder how it is planned to be used in non-Gnome desktops though!
Comment 19 Sergey Bostandzhyan 2016-02-15 17:13:14 EST
Felix, thank you for the hint. I ran into the same problem today and luckily downgrading did work for me.
Comment 20 Fedora Update System 2016-02-17 01:25:24 EST
hamster-time-tracker-2.0-0.3.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c97f297cd6
Comment 21 Fedora Update System 2016-02-17 01:28:46 EST
hamster-time-tracker-2.0-0.3.rc1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d556fdafa
Comment 22 Fedora Update System 2016-02-17 15:52:21 EST
hamster-time-tracker-2.0-0.3.rc1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Brandon J. Wyman 2016-02-18 13:35:41 EST
I finally did get the new version installed, and it was not crashing. The interface change was also a bit of a surprise and annoyance for me. 

On a whim, I tired a google search for "xfce time tracker" and found that here is a xfce4-hamster-plugin. :-)

https://github.com/projecthamster/xfce4-hamster-plugin

$ sudo dnf search xfce4-hamster-plugin
Contacting OpenClient Router for restricted repository information
Added restricted repo: RHEL-7-x86_64-crashplan
Added restricted repo: Fedora-23-x86_64-Licensed
Last metadata expiration check performed 0:14:17 ago on Thu Feb 18 12:17:36 2016.
============================================== N/S Matched: xfce4-hamster-plugin ==============================================
xfce4-hamster-plugin.x86_64 : Time tracker port of the 'hamster project extension' for the xfce4 panel
$ sudo dnf install xfce4-hamster-plugin
Contacting OpenClient Router for restricted repository information
Added restricted repo: RHEL-7-x86_64-crashplan
Added restricted repo: Fedora-23-x86_64-Licensed
Last metadata expiration check performed 0:14:37 ago on Thu Feb 18 12:17:36 2016.
Dependencies resolved.
===============================================================================================================================
 Package                                Arch                     Version                        Repository                Size
===============================================================================================================================
Installing:
 xfce4-hamster-plugin                   x86_64                   1.6.1-2.fc23                   fedora                    60 k

Transaction Summary
===============================================================================================================================
Install  1 Package

Total download size: 60 k
Installed size: 218 k
Is this ok [y/N]: y
Downloading Packages:
xfce4-hamster-plugin-1.6.1-2.fc23.x86_64.rpm                                                    45 kB/s |  60 kB     00:01    
-------------------------------------------------------------------------------------------------------------------------------
Total                                                                                           26 kB/s |  60 kB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : xfce4-hamster-plugin-1.6.1-2.fc23.x86_64                                                                   1/1 
  Verifying   : xfce4-hamster-plugin-1.6.1-2.fc23.x86_64                                                                   1/1 

Installed:
  xfce4-hamster-plugin.x86_64 1.6.1-2.fc23                                                                                     

Complete!
$ 

Hope that helps for the non-Gnome users. :-)
Comment 24 Sergey Bostandzhyan 2016-02-19 04:47:02 EST
I can also confirm that the new package fixes the crash, but indeed - the interface was terrible and from what I read they are dropping gtk2 support and since I am running MATE the xfce plugin will probably not help me :( For now I downgraded to the older version again :P
Comment 25 Fedora Update System 2016-02-25 03:52:29 EST
hamster-time-tracker-2.0-0.3.rc1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.