Bug 1307258 - [abrt] firefox: nsProfileLock::FatalSignalHandler(): firefox killed by SIGSEGV
[abrt] firefox: nsProfileLock::FatalSignalHandler(): firefox killed by SIGSEGV
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:bbd6f816f13f096924d504f27fe...
:
: 1308717 1308724 1310424 1318932 1321439 1322663 1324611 1326960 1328331 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-13 12:56 EST by Vedran Miletić
Modified: 2017-04-24 18:26 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-24 18:26:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (317.12 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: cgroup (242 bytes, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: core_backtrace (24.31 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: dso_list (17.15 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: environ (2.27 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: limits (1.29 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: maps (85.30 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: mountinfo (3.43 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: namespaces (85 bytes, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: open_fds (12.35 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details
File: var_log_messages (17.21 KB, text/plain)
2016-02-13 12:56 EST, Vedran Miletić
no flags Details

  None (edit)
Description Vedran Miletić 2016-02-13 12:56:05 EST
Description of problem:
Opened multiple tabs

Version-Release number of selected component:
firefox-44.0.2-3.fc24

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     18170
kernel:         4.5.0-0.rc3.git2.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 nsProfileLock::FatalSignalHandler at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/toolkit/profile/nsProfileLock.cpp:185
 #3 js::TenuringTracer::traverse<JSObject> at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/gc/Marking.cpp:1915
 #4 js::frontend::ObjectBox::trace at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/frontend/ParseNode.cpp:1175
 #5 js::frontend::Parser<js::frontend::FullParseHandler>::trace at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/frontend/Parser.cpp:810
 #6 js::frontend::MarkParser at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/frontend/Parser.cpp:816
 #7 JS::AutoGCRooter::trace at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/gc/RootMarking.cpp:89
 #8 JS::AutoGCRooter::traceAllInContext<JSContext> at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/jspubtd.h:206
 #9 JS::AutoGCRooter::traceAll at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/gc/RootMarking.cpp:162
 #10 js::gc::GCRuntime::markRuntime at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/gc/RootMarking.cpp:278
 #11 js::Nursery::collect at /usr/src/debug/firefox-44.0.2/firefox-44.0.2/js/src/gc/Nursery.cpp:464
Comment 1 Vedran Miletić 2016-02-13 12:56:10 EST
Created attachment 1123858 [details]
File: backtrace
Comment 2 Vedran Miletić 2016-02-13 12:56:11 EST
Created attachment 1123859 [details]
File: cgroup
Comment 3 Vedran Miletić 2016-02-13 12:56:13 EST
Created attachment 1123860 [details]
File: core_backtrace
Comment 4 Vedran Miletić 2016-02-13 12:56:14 EST
Created attachment 1123861 [details]
File: dso_list
Comment 5 Vedran Miletić 2016-02-13 12:56:16 EST
Created attachment 1123862 [details]
File: environ
Comment 6 Vedran Miletić 2016-02-13 12:56:17 EST
Created attachment 1123863 [details]
File: limits
Comment 7 Vedran Miletić 2016-02-13 12:56:19 EST
Created attachment 1123864 [details]
File: maps
Comment 8 Vedran Miletić 2016-02-13 12:56:20 EST
Created attachment 1123865 [details]
File: mountinfo
Comment 9 Vedran Miletić 2016-02-13 12:56:22 EST
Created attachment 1123866 [details]
File: namespaces
Comment 10 Vedran Miletić 2016-02-13 12:56:23 EST
Created attachment 1123867 [details]
File: open_fds
Comment 11 Vedran Miletić 2016-02-13 12:56:25 EST
Created attachment 1123868 [details]
File: proc_pid_status
Comment 12 Vedran Miletić 2016-02-13 12:56:26 EST
Created attachment 1123869 [details]
File: var_log_messages
Comment 13 Ilya Gradina 2016-02-15 16:03:19 EST
*** Bug 1308717 has been marked as a duplicate of this bug. ***
Comment 14 Ilya Gradina 2016-02-15 16:08:10 EST
*** Bug 1308724 has been marked as a duplicate of this bug. ***
Comment 15 Andrew Cook 2016-02-19 04:00:41 EST
Similar problem has been detected:

After accidentally closing firefox, it would consistently crash on statup
Launching in safe mode once fixed the crash

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     8425
kernel:         4.5.0-0.rc3.git3.1.fc24.x86_64
package:        firefox-44.0.2-3.fc24
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 16 lex0tanil 2016-02-21 07:56:55 EST
*** Bug 1310424 has been marked as a duplicate of this bug. ***
Comment 17 Jan Kurik 2016-02-24 09:31:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 18 Han Han 2016-03-01 22:32:30 EST
Similar problem has been detected:

Crashed when operate RHEVM.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox https://retrace.fedoraproject.org/faf/reports/bthash/72329f6494f541d2928d9a29d615dab727366373
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     7146
kernel:         4.5.0-0.rc5.git0.1.fc24.x86_64
package:        firefox-44.0.2-3.fc24
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 19 Michal Schmidt 2016-03-18 04:13:09 EDT
*** Bug 1318932 has been marked as a duplicate of this bug. ***
Comment 20 Heiko Adams 2016-03-21 13:48:40 EDT
Similar problem has been detected:

Just wanted to start firefox and then it crashed

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     2622
kernel:         4.4.5-300.fc23.x86_64
package:        firefox-45.0-4.fc24
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 21 Giulio 'juliuxpigface' 2016-03-24 18:51:00 EDT
Similar problem has been detected:

I launched Firefox and it crashed. Sorry if I can't be more verbose, but I can't reproduce the issue.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     3992
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
package:        firefox-45.0.1-2.fc24
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 22 Andrew Cook 2016-03-26 22:12:47 EDT
*** Bug 1321439 has been marked as a duplicate of this bug. ***
Comment 23 Han Han 2016-03-30 12:13:23 EDT
Similar problem has been detected:

Firefox crashed after installing NoScript plugin and restarted firefox

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     10377
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
package:        firefox-45.0.1-2.fc24
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 24 Dan Beard 2016-03-30 23:33:37 EDT
*** Bug 1322663 has been marked as a duplicate of this bug. ***
Comment 25 lejeczek 2016-04-06 15:04:20 EDT
*** Bug 1324611 has been marked as a duplicate of this bug. ***
Comment 26 Han Han 2016-04-07 21:53:10 EDT
Similar problem has been detected:

Crashed when open RHEVM.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/firefox/firefox
global_pid:     17338
kernel:         4.5.0-302.fc24.x86_64
package:        firefox-45.0.1-6.fc24
reason:         firefox killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 27 Steven Usdansky 2016-04-13 18:47:32 EDT
*** Bug 1326960 has been marked as a duplicate of this bug. ***
Comment 28 Andrey Motoshkov 2016-04-19 02:56:44 EDT
*** Bug 1328331 has been marked as a duplicate of this bug. ***
Comment 29 Joachim Frieben 2016-07-19 16:57:34 EDT
Issue appears to be fixed by upgrading to xorg-x11-server-1.18.4-1.fc24.

Note You need to log in before you can comment on or make changes to this bug.