Bug 1307260 - systemd long shutdown: A stop job is running for Session 1 of user x
systemd long shutdown: A stop job is running for Session 1 of user x
Status: NEW
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
25
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-13 13:39 EST by Joseph D. Wagner
Modified: 2017-11-16 14:04 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 02:56:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph D. Wagner 2016-02-13 13:39:25 EST
I upgraded systemd from 228-9.gite35a787 to 229-1.  Now, shutdown runs long with the message "A stop job is running for Session 1 of user joseph."

I'm not sure what info you need from me. Please be patient!  I'm not an expert, just someone who's willing to test.

# journalctl -b -1 -u session-1.scope
-- Logs begin at Fri 2015-05-01 11:21:59 PDT, end at Sat 2016-02-13 10:31:50 PST. --
Feb 13 10:10:23 localhost.localdomain systemd[1]: Started Session 1 of user joseph.
Feb 13 10:10:23 localhost.localdomain lightdm[1054]: pam_unix(lightdm:session): session opened for user joseph by (uid=0)
Feb 13 10:10:24 localhost.localdomain pulseaudio[1361]: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because running inside a VM
Feb 13 10:10:24 localhost.localdomain pulseaudio[1361]: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because running inside a VM
Feb 13 10:10:36 localhost.localdomain su[1535]: (to root) joseph on pts/0
Feb 13 10:10:36 localhost.localdomain su[1535]: pam_systemd(su:session): Cannot create session: Already running in a session
Feb 13 10:10:36 localhost.localdomain su[1535]: pam_unix(su:session): session opened for user root by joseph(uid=1000)
Feb 13 10:13:41 localhost.localdomain su[1535]: pam_unix(su:session): session closed for user root
Feb 13 10:13:52 localhost.localdomain systemd[1]: Stopping Session 1 of user joseph.
Feb 13 10:15:22 localhost.localdomain systemd[1]: session-1.scope: Stopping timed out. Killing.
Feb 13 10:15:22 localhost.localdomain systemd[1]: Stopped Session 1 of user joseph.
Feb 13 10:15:22 localhost.localdomain systemd[1]: session-1.scope: Unit entered failed state.
Comment 1 Jan Synacek 2016-02-15 02:52:52 EST
Why do you think this is a bug and what should be the expected behavior?
Comment 2 Jan Synacek 2016-02-15 04:07:52 EST
(In reply to Joseph D. Wagner from comment #0)
> Feb 13 10:13:52 localhost.localdomain systemd[1]: Stopping Session 1 of user
> joseph.
> Feb 13 10:15:22 localhost.localdomain systemd[1]: session-1.scope: Stopping
> timed out. Killing.

Oh, I didn't realize this was the problem. Monday morning...
Comment 3 Joseph D. Wagner 2016-02-15 14:55:41 EST
I installed the latest rawhide updates below, and now the problem went away.

Feb 15 11:47:00 DEBUG --> Starting dependency resolution
Feb 15 11:47:01 DEBUG ---> Package python3-ordered-set.noarch 2.0.0-3.fc24 will be installed
Feb 15 11:47:01 DEBUG ---> Package kernel.x86_64 4.5.0-0.rc3.git3.1.fc24 will be installed
Feb 15 11:47:01 DEBUG ---> Package kernel-core.x86_64 4.5.0-0.rc3.git3.1.fc24 will be installed
Feb 15 11:47:01 DEBUG ---> Package kernel-modules.x86_64 4.5.0-0.rc3.git3.1.fc24 will be installed
Feb 15 11:47:01 DEBUG ---> Package kernel-modules-extra.x86_64 4.5.0-0.rc3.git3.1.fc24 will be installed
Feb 15 11:47:01 DEBUG ---> Package PackageKit-glib.x86_64 1.0.11-2.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package PackageKit-glib.x86_64 1.1.0-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package PackageKit-gstreamer-plugin.x86_64 1.0.11-2.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package PackageKit-gstreamer-plugin.x86_64 1.1.0-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package anaconda-core.x86_64 24.11-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package anaconda-core.x86_64 24.12-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package anaconda-tui.x86_64 24.11-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package anaconda-tui.x86_64 24.12-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package anaconda-gui.x86_64 24.11-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package anaconda-gui.x86_64 24.12-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package anaconda-widgets.x86_64 24.11-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package anaconda-widgets.x86_64 24.12-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package cpp.x86_64 6.0.0-0.10.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package cpp.x86_64 6.0.0-0.11.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package gcc.x86_64 6.0.0-0.10.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package gcc.x86_64 6.0.0-0.11.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package gcc-gdb-plugin.x86_64 6.0.0-0.10.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package gcc-gdb-plugin.x86_64 6.0.0-0.11.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package libgcc.x86_64 6.0.0-0.10.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package libgcc.x86_64 6.0.0-0.11.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package libgomp.x86_64 6.0.0-0.10.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package libgomp.x86_64 6.0.0-0.11.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package gdb.x86_64 7.10.50.20160131-51.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package gdb.x86_64 7.10.90.20160211-52.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package glibc.x86_64 2.22.90-33.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package glibc.x86_64 2.22.90-34.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package glibc-common.x86_64 2.22.90-33.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package glibc-common.x86_64 2.22.90-34.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package glibc-headers.x86_64 2.22.90-33.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package glibc-headers.x86_64 2.22.90-34.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package glibc-devel.x86_64 2.22.90-33.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package glibc-devel.x86_64 2.22.90-34.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package jack-audio-connection-kit.x86_64 1.9.10-3.fc23 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package jack-audio-connection-kit.x86_64 1.9.10-5.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package jack-audio-connection-kit-example-clients.x86_64 1.9.10-3.fc23 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package jack-audio-connection-kit-example-clients.x86_64 1.9.10-5.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package kernel-headers.x86_64 4.5.0-0.rc3.git2.1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package kernel-headers.x86_64 4.5.0-0.rc3.git3.1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package libsrtp.x86_64 1.5.4-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package libsrtp.x86_64 1.5.4-2.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package libstdc++.x86_64 6.0.0-0.10.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package libstdc++.x86_64 6.0.0-0.11.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package llvm.x86_64 3.7.1-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package llvm.x86_64 3.7.1-6.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package llvm-libs.x86_64 3.7.1-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package llvm-libs.x86_64 3.7.1-6.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libxatracker.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libxatracker.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-dri-drivers.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-dri-drivers.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-filesystem.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-filesystem.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libEGL.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libEGL.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libEGL-devel.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libEGL-devel.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libGL.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libGL.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libGL-devel.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libGL-devel.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libgbm.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libgbm.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libglapi.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libglapi.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libwayland-egl.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libwayland-egl.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package mesa-libwayland-egl-devel.x86_64 11.2.0-0.devel.9.24ea81a.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package mesa-libwayland-egl-devel.x86_64 11.2.0-0.devel.10.24ea81a.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package nano.x86_64 2.5.1-2.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package nano.x86_64 2.5.2-2.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package python2-setuptools.noarch 20.0-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package python2-setuptools.noarch 20.1.1-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package python3-setuptools.noarch 20.0-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package python3-setuptools.noarch 20.1.1-1.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package soundtouch.x86_64 1.4.0-14.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package soundtouch.x86_64 1.9.2-3.fc24 will be an upgrade
Feb 15 11:47:01 DEBUG ---> Package xdg-utils.noarch 1.1.1-1.fc24 will be upgraded
Feb 15 11:47:01 DEBUG ---> Package xdg-utils.noarch 1.1.1-2.fc24 will be an upgrade
Comment 4 Felix Miata 2016-03-11 03:49:37 EST
I have multiple F24 installations repeatedly doing this since before this bug was opened, and still doing it after it was closed, except that the running stop job belongs to Session 1 of user root. Updating has been no help. Excess delay is at least 1.5 minutes each reboot.
Comment 5 Jan Kurik 2016-07-26 01:06:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 6 Fedora End Of Life 2017-11-16 14:04:17 EST
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Note You need to log in before you can comment on or make changes to this bug.